Migrated jobs (6.3.1 -> 6.5.1) don't run

Four Stars

Migrated jobs (6.3.1 -> 6.5.1) don't run

Hello

We are using Talend v6.3.1. For testing purposes, we've set up Talend v6.5.1. We exported an existing project from the old version and imported it to the new one. We installed all missing jars and modules, there are no errors in the code. However, when we try to run it, we get: 

Exception in thread "main" java.lang.Error: Unresolved compilation problems:

I saw somewhere that checking File -> Edit Project properties -> Job Settings -> Use Project Settings might help so I've tried it. After that, we always get 

Error: Could not find or load main class

None of the imported jobs work, it's always the same issue.

A fresh job made from scratch runs without a problem, so I don't think it's a configuration issue...
Any suggestions?

Seven Stars

Re: Migrated jobs (6.3.1 -> 6.5.1) don't run

Hi,

 

When you click on the "Code" tab in Studio, it should point out what the problem is - or at least point you in the direction of the component that's having the problem.

 

Thanks

 

David

Regards

David

Don't forget to give Kudos when an answer is helpful or the solution.
Four Stars

Re: Migrated jobs (6.3.1 -> 6.5.1) don't run

Hello and thank you for taking interest in the subject.

Actually, that's the first thing we do when we migrate. There are no errors in the code view. No errors in the designer view about missing jars either.



Seven Stars

Re: Migrated jobs (6.3.1 -> 6.5.1) don't run

Next suggestion then, deactivate 90% of the job, see if it runs, gradually activating sub-jobs until it stops working.

 

Thanks

 

David

Regards

David

Don't forget to give Kudos when an answer is helpful or the solution.
Four Stars

Re: Migrated jobs (6.3.1 -> 6.5.1) don't run

 Hi,

Yeah, that makes sense as a step. We'll give it a go. Hopefully, we won't have to do the same for all of our implementations
Thanks for the suggestion

Four Stars

Re: Migrated jobs (6.3.1 -> 6.5.1) don't run

I have the same issue a lot of the jobs after upgrade give me this error. Did you have luck finding a solution?

 

Moderator

Re: Migrated jobs (6.3.1 -> 6.5.1) don't run

Hello,

Is there any error  in the code? The compile error will be highlighted in red line.

Are you able to run your jobs successfully in your previous version?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.