Log4j enabled : i don't have the checkbox

One Star

Log4j enabled : i don't have the checkbox

Hi,
I'm using TOS DI 5.6.1 and normaly Log4j is automatically activated starting from version 5.6.1.
I would like active Log4j with it :
But, i don't have at the begining the checkox "Activate log4j in components"
Do you have an idea ?
Thanks !
Moderator

Re: Log4j enabled : i don't have the checkbox

Hi,
The log4j feature is only available in Talend Enterprise Subscription Version.
Please take a look at KB article about:TalendHelpCenter:How to activate log4j in Talend Studio?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Log4j enabled : i don't have the checkbox

Hi Sabrina,
I already read this article and i always have the same problem.
When i build my job, there is my error :
log4j:WARN No appenders could be found for logger (org.apache.james.mime4j.util.CharsetUtil).
log4j:WARN Please initialize the log4j system properly.
May be it's this bug ? ( jira.talendforge.org - TDI-32297 )
Thanks !
NB: i have an account but when i log me in, i'm redirecting on this forum like a guest !
One Star

Re: Log4j enabled : i don't have the checkbox

I have the same warnings on my Talend 5.6.1. It is a community edition. Here is the warnings
log4j:ERROR DOM element is - not a <log4j:configuration> element.
log4j:WARN No appenders could be found for logger (org.apache.http.impl.conn.PoolingClientConnectionManager).
log4j:WARN Please initialize the log4j system properly.
Seventeen Stars

Re: Log4j enabled : i don't have the checkbox

That happens because the under-laying library use log4j but this will not be initialized by the job.
You can do this in a simply way with:
tLoadLibary -> load log4j-1.2.17.jar (download it from the apache web site to your local pc and point to it
Use a tJava with this code: 
org.apache.log4j.BasicConfigurator.configure();

This will give you a meaningful logger and the output to the console.