Six Stars

Job won't build from second time and fails after first successful run of opening a studio in new workspace

I just installed Talend Data fabric 6.4.1 Enterprise edition, I am unable to run the job second time on a remote server, while I am able to run it very first time I create a new workspace.

Please help, any thoughts/suggestions are most welcome.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Error message in studio : Execution failed : java.lang.Exception: Job was not built successfully, please check the logs for more details available on the workspace/.Java/lastGenerated.log
[Job was not built successfully, please check the logs for more details available on the workspace/.Java/lastGenerated.log]

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Error log file :

[INFO] Scanning for projects...
[INFO]
[INFO] Reactor Build Order:
[INFO]
[INFO] RDL_POC Codes Master
[INFO] RDL_POC Routines
[INFO] RDL_POC loading_afile_to_db_using_localContexts (Job Designs)
[INFO]
[INFO] Using the builder org.apache.maven.lifecycle.internal.builder.multithreaded.MultiThreadedBuilder with a thread count of 4
[INFO]                                                                         
[INFO] ------------------------------------------------------------------------
[INFO] Building RDL_POC Codes Master 6.4.1
[INFO] ------------------------------------------------------------------------
[INFO]                                                                         
[INFO] ------------------------------------------------------------------------
[INFO] Building RDL_POC loading_afile_to_db_using_localContexts (Job Designs) 0.1.0
[INFO] ------------------------------------------------------------------------
[INFO]                                                                         
[INFO] ------------------------------------------------------------------------
[INFO] Building RDL_POC Routines 6.4.1
[INFO] ------------------------------------------------------------------------
[INFO]
[INFO] --- maven-resources-plugin:2.7:resources (default-resources) @ routines ---
[INFO]
[INFO] --- maven-resources-plugin:2.7:resources (default-resources) @ loading_afile_to_db_using_localContexts ---
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] Copying 45 resources
[INFO] Copying 0 resource
[INFO]
[INFO] --- maven-compiler-plugin:2.5.1:compile (default-compile) @ loading_afile_to_db_using_localContexts ---
[INFO]
[INFO] --- maven-compiler-plugin:2.5.1:compile (default-compile) @ routines ---
[INFO] Nothing to compile - all classes are up to date
[INFO]
[INFO] --- maven-resources-plugin:2.7:copy-resources (copy-running-resources) @ loading_afile_to_db_using_localContexts ---
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] Copying 1 resource
[INFO]
[INFO] --- maven-resources-plugin:2.7:testResources (default-testResources) @ loading_afile_to_db_using_localContexts ---
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] Copying 0 resource
[INFO]
[INFO] --- maven-compiler-plugin:2.5.1:testCompile (default-testCompile) @ loading_afile_to_db_using_localContexts ---
[INFO] Nothing to compile - all classes are up to date
[INFO]
[INFO] --- maven-surefire-plugin:2.12.4:test (default-test) @ loading_afile_to_db_using_localContexts ---
[INFO] Nothing to compile - all classes are up to date
[INFO]
[INFO] --- maven-resources-plugin:2.7:testResources (default-testResources) @ routines ---
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] Copying 0 resource
[INFO]
[INFO] --- maven-compiler-plugin:2.5.1:testCompile (default-testCompile) @ routines ---
[INFO] Nothing to compile - all classes are up to date
[INFO]
[INFO] --- maven-surefire-plugin:2.12.4:test (default-test) @ routines ---
[INFO] Tests are skipped.
[INFO]
[INFO] --- maven-jar-plugin:2.6:jar (default-jar) @ routines ---
[INFO] Tests are skipped.
[INFO]
[INFO] --- maven-jar-plugin:2.6:jar (default-jar) @ loading_afile_to_db_using_localContexts ---
[INFO] Building jar: C:\software\RDL_Talend_Installation\workspace\.Java\target\loading_afile_to_db_using_localcontexts_0_1.jar
[INFO]
[INFO] --- maven-assembly-plugin:2.5.5:single (default) @ loading_afile_to_db_using_localContexts ---
[INFO] Building jar: C:\software\RDL_Talend_Installation\workspace\.Java\target\routines-6.4.1.jar
[INFO] Reading assembly descriptor: C:\software\RDL_Talend_Installation\workspace\.Java/src/main/assemblies/assembly_loading_afile_to_db_using_localContexts_0.1.xml
[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO]
[INFO] RDL_POC Codes Master .............................. SUCCESS [  0.003 s]
[INFO] RDL_POC Routines .................................. SKIPPED
[INFO] RDL_POC loading_afile_to_db_using_localContexts (Job Designs)  FAILURE [  3.811 s]
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 4.043 s (Wall Clock)
[INFO] Finished at: 2017-11-16T18:47:16-05:00
[INFO] Final Memory: 13M/241M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-assembly-plugin:2.5.5:single (default) on project loading_afile_to_db_using_localContexts: Failed to create assembly: Error adding file 'org.talend.code.rdl_poc:routines:jar:6.4.1' to archive: C:\software\RDL_Talend_Installation\workspace\.Java\target\classes isn't a file. -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
[ERROR]
[ERROR] After correcting the problems, you can resume the build with the command
[ERROR]   mvn <goals> -rf :loading_afile_to_db_using_localContexts

.

Thanks in advance!

3 REPLIES
Moderator

Re: Job won't build from second time and fails after first successful run of opening a studio in new workspace

Hi,

It looks like an existed bug created on talend bug tracker. https://jira.talendforge.org/browse/TUP-18118

We would suggest that you create a case on talend support portal so that our colleagues from support portal will check your issue to see if it is a bug and give a patch to you if need be.

https://login.talend.com/support-login.php.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Moderator

Re: Job won't build from second time and fails after first successful run of opening a studio in new workspace

Hello,

Have you already created a case on talend support portal? Feel free to let us know if there is any help we can give.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Six Stars

Re: Job won't build from second time and fails after first successful run of opening a studio in new workspace

I don't find the link https://jira.talendforge.org/browse/TUP-18118 on this issue. Is there any other link the refer to this issue ?