One Star

Java error preventing installation on mac.

Hi There!
I'm trying to install Talend Open Studio for ESB (Version 6.0.1) on Mac (OS X Yosemite - Version 10.10.5) but when i start the .app (TOS_ESB-macosx-cocoa) this error occurs:
Alert:
The JVM shared library "/Library/Internet Plug-ing/JavaApplePluggin.plugin/Contens/Home/bin/.../lib/server/libjvm.dylib"does not contain the JNI_CreateJavaVM symbol. 
I have the latest version of java jdk installed on my Mac (Version 8 update 60). See details below
java version "1.8.0_60"
Java(TM) SE Runtime Environment (build 1.8.0_60-b27)
Java HotSpot(TM) 64-Bit Server VM (build 25.60-b23, mixed mode)
Can u guys give some help?
Thanks!
2 REPLIES
Moderator

Re: Java error preventing installation on mac.

Hi marcos.freitas,
You are using 64 bit JDK? Did you also start 64 bit app(TOS_ESB-macosx-cocoa-x86)?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Java error preventing installation on mac.

There's no choice for x86 or x64 on Mac OS...
What solved it for me was to add:
-vm
/Library/Java/JavaVirtualMachines/jdk1.8.0_60.jdk/Contents/Home/jre/lib/server/libjvm.dylib

before "-vmargs" in TOS_DI-macosx-cocoa.ini... Finally my file looks like that:
--launcher.XXMaxPermSize
512m
-vm
/Library/Java/JavaVirtualMachines/jdk1.8.0_60.jdk/Contents/Home/jre/lib/server/libjvm.dylib
-vmargs
-Xms64m
-Xmx768m
-Xdock:icon=../Resources/talend.icns
-XstartOnFirstThread
-Dorg.eclipse.swt.internal.carbon.smallFonts
-Dosgi.instance.area.default=../../../workspace
-Dfile.encoding=UTF-8

hope it save's someone else 15Min's of worthless googling!