Seven Stars

Java - Xmx memory - 512M only

root     31971  6.1  4.4 3034712 366832 ?      Sl   16:09   0:29 /usr/lib/jvm/jre-1.7.0-openjdk.x86_64/bin/java -Dkaraf.home=/data/talend/tesb/Runtime_ESBSE/container -Dkaraf.base=/data/talend/tesb/Runtime_ESBSE/container -Dkaraf.data=/data/talend/tesb/Runtime_ESBSE/container/data -Dkaraf.etc=/data/talend/tesb/Runtime_ESBSE/container/etc -Dcom.sun.management.jmxremote -Dkaraf.startLocalConsole=false -Dkaraf.startRemoteShell=true -Djava.endorsed.dirs=/usr/lib/jvm/jre-1.7.0-openjdk.x86_64/jre/lib/endorsed:/usr/lib/jvm/jre-1.7.0-openjdk.x86_64/lib/endorsed:/data/talend/tesb/Runtime_ESBSE/container/lib/endorsed -Djava.ext.dirs=/usr/lib/jvm/jre-1.7.0-openjdk.x86_64/jre/lib/ext:/usr/lib/jvm/jre-1.7.0-openjdk.x86_64/lib/ext:/data/talend/tesb/Runtime_ESBSE/container/lib/ext -Xmx512m -Djava.library.path=/data/talend/tesb/Runtime_ESBSE/container/lib/wrapper/ -classpath /data/talend/tesb/Runtime_ESBSE/container/lib/boot/jna-4.2.2.jar:/data/talend/tesb/Runtime_ESBSE/container/lib/boot/jna-platform-4.2.2.jar:/data/talend/tesb/Runtime_ESBSE/container/lib/boot/org.apache.karaf.diagnostic.boot-4.0.7.jar:/data/talend/tesb/Runtime_ESBSE/container/lib/boot/org.osgi.core-6.0.0.jar:/data/talend/tesb/Runtime_ESBSE/container/lib/boot/org.apache.karaf.jaas.boot-4.0.7.jar:/data/talend/tesb/Runtime_ESBSE/container/lib/boot/org.apache.karaf.main-4.0.7.jar:/data/talend/tesb/Runtime_ESBSE/container/lib/wrapper/karaf-wrapper.jar:/data/talend/tesb/Runtime_ESBSE/container/lib/wrapper/karaf-wrapper-main.jar -Dwrapper.key=gcxP6BJCchqva9qb -Dwrapper.port=32000 -Dwrapper.jvm.port.min=31000 -Dwrapper.jvm.port.max=31999 -Dwrapper.pid=31969 -Dwrapper.version=3.2.3 -Dwrapper.native_library=wrapper -Dwrapper.service=TRUE -Dwrapper.cpu.timeout=10 -Dwrapper.jvmid=1 org.apache.karaf.wrapper.internal.service.Main

I am currently running talend ESB on a linux container and noticed that it is having Xmx set at 512 (according to the ps command).

 

I have set the correct memory configs in <runtime container>/bin/setmem as:

 

    if [ ${JAVA_VERSION_MINOR} -lt 8 ]; then
        if [ -z "${JAVA_PERM_MEM}" ]; then
            if ${JAVA_SIXTY_FOUR}; then
                JAVA_PERM_MEM=1024M
            else
                JAVA_PERM_MEM=1024M
            fi
            export JAVA_PERM_MEM
        fi

        if [ -z "${JAVA_MAX_PERM_MEM}" ]; then
            if ${JAVA_SIXTY_FOUR}; then
                JAVA_MAX_PERM_MEM=8096M
            else
                JAVA_MAX_PERM_MEM=8096M
            fi
            export JAVA_MAX_PERM_MEM
        fi
    fi

So why would that not work as expected? Or the xmx refers to something else?

 

I am running this as a wrapper service.

Please help.

1 ACCEPTED SOLUTION

Accepted Solutions
Twelve Stars

Re: Java - Xmx memory - 512M only

If you are running this using the service wrapper, take a look here: https://help.talend.com/reader/kXw5G19CjSNyX9CeQ_cEgQ/_dPb2wr4Rl2EwYdYylaRfQ

 

I imagine you are missing a couple of "wrapper.java.additional.n" lines (you need to add these) with your JVM settings. The web page I have posted talks about this...albeit a little briefly.

Rilhia Solutions
3 REPLIES
Twelve Stars

Re: Java - Xmx memory - 512M only

If you are running this using the service wrapper, take a look here: https://help.talend.com/reader/kXw5G19CjSNyX9CeQ_cEgQ/_dPb2wr4Rl2EwYdYylaRfQ

 

I imagine you are missing a couple of "wrapper.java.additional.n" lines (you need to add these) with your JVM settings. The web page I have posted talks about this...albeit a little briefly.

Rilhia Solutions
Seven Stars

Re: Java - Xmx memory - 512M only

Wow, I thought setting the options in setmem file should do the magic. I never knew about this configuration (alas, I did not read the documentation earlier Smiley Very Happy during the initial setup).
Thank you
Twelve Stars

Re: Java - Xmx memory - 512M only

Did this resolve your question? If so can you set it to resolved so that others can benefit from this?

Rilhia Solutions