One Star

Installation fails with connection error for runtime client

Hi,
I try to install the talend server on a rhel machine. I installed the latest jdk. When I try to install talend I get the following error message:
/talend/runtime/bin/client -a 8101 -h localhost -u xxxx -p xxxxxx
I'm using the embedded H2 database. There was a previous version of talend installed, but due to some tomcat/tac problems I decided to make a fresh installation and ran therefore the uninstall script. Now I get the above message. Are there any additional files I have to delete?
Regards
Tobias
edit: I found out, by starting the h2 database manually, that it fails
because it can't connect to the 'life-vsrv-015.xxxx.xx'. Which is the
hostname of the machine. When I start it with the option -url localhost,
it can't find a suitable driver.
edit2: I forgot to add the whole error message. Sorry. That's a little
bit embarrassing. Here it is:
/talend/runtime/bin/client -a 8101 -h localhost -u xxxx -p xxxxxx
'features:install wrapper' : Failed to get the session.
edit3: Anyone any suggestions? I tried it on a different server with the
same result. I tried both, customized and default installation. Nothing
works.
edit4: It can't be an firewall issue, because the port 8101 is open and
selinux is disabled as well
edit5: It is definitely a problem with the driver for the H2 database.
So I installed the package hsqldb via yum in hope that it will install the
necessary drivers but it didn't work.
edit6: It is a redhat server minimal installation. I did a
#yum groupinstall "Java Platform" "Server Development tools"
additionally I installed sun jdk in version 1.7.0.7. But it still seems,
that there are some packages missing, but I can't find out which ones.
Anybody any suggestions?
2 REPLIES
One Star

Re: Installation fails with connection error for runtime client

Anyone any suggestions?
One Star

Re: Installation fails with connection error for runtime client

Does karaf need any special configuration or additional packages? I tried to connect to port 8101 via the talend client, via telnet and via openssl I always get a 'connection refused'. Iptables is turned of and I added the hostname to /etc/hosts (with 127.0.0.1 and the IP in the net).