InputFileExcel doesn't get header from first sheet

Five Stars

InputFileExcel doesn't get header from first sheet

 

Hello everyone, its me again.

 

When i use a tInputFileExcel, as you can see at image below, the component doesn't return the header of first sheet file as a line, if i have two sheets, for the sheet two the component returns. What am i doing wrong?

 

Tks

 

image.png

Tags (1)
Six Stars

Re: InputFileExcel doesn't get header from first sheet

With tFileInputExcel there are two cases:
1) Using .xls file (97-2003 format), then Uncheck the "Read excel2007 file format" option. It will not show you any error.
2) Using .xlsx file, then check the "Read excel2007 file format" option.

Try this, hope it will work.

Note: Specify the schema for excelsheet as well. And define a schema that has the maximum number of columns you can expect in all of your sheets.
Also Please let me know the output file component type, so that I can research on this. By the way I didn't find any wrong with your job.


Let me know if you require anything else.


Regards,
Mohit
Seven Stars

Re: InputFileExcel doesn't get header from first sheet

Hi,

 

As far as I could see from your post 

Please configure the header row number, which I could see zero now.

If you choose all sheets option, all sheets should be with the same format.

If it's a different format, you may have to use new metadata created in talend. 

 

Cheers!

Gatha

 

Five Stars

Re: InputFileExcel doesn't get header from first sheet

Hi mks02, thanks for your answer.

I'm using xlsx files, thus the option "Read excel2007" is checked.
I understood your solution, but, the problem i have thought that is a talend bug,because, if I have an excel table without header, i'll loose the first line of data. It doesn't make sense.

Five Stars

Re: InputFileExcel doesn't get header from first sheet

Hi Gatha, tks for your help too.
I have made tests with the component tFileInputExcel, if source file has only one sheet and component is set to use dynamic schema, i'll loose the first line of data. Perhaps its a bug. I have the version 6.1 of Talend, and did a test with 6.2 too.

Calling Talend Open Studio Users

The first 100 community members completing the Open Studio survey win a $10 gift voucher.

Start the survey

2019 GARNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

Best Practices for Using Context Variables with Talend – Part 4

Pick up some tips and tricks with Context Variables

Blog

How Media Organizations Achieved Success with Data Integration

Learn how media organizations have achieved success with Data Integration

Read

6 Ways to Start Utilizing Machine Learning with Amazon We Services and Talend

Look at6 ways to start utilizing Machine Learning with Amazon We Services and Talend

Blog