One Star

Initial setting to connect to remote hadoop system

TOS 5.1.2.r90681 is installed on my local system (WindowsXP OS), I need to connect to a remote server where the hdfs system is located(Ubuntu OS) . I need to put a file from my local to the remote server . I have used the thdfsput component and have provided the correct host IP address as well as the port number. But for some reason have encountered this error:
xception in component tHDFSPut_1 Call to / failed on local exception:
at org.apache.hadoop.ipc.Client.wrapException(
at org.apache.hadoop.ipc.RPC$Invoker.invoke(
at $Proxy0.getProtocolVersion(Unknown Source)
at org.apache.hadoop.ipc.RPC.getProxy(
at org.apache.hadoop.hdfs.DFSClient.createRPCNamenode(
at org.apache.hadoop.hdfs.DFSClient.<init>(
at org.apache.hadoop.hdfs.DFSClient.<init>(
at org.apache.hadoop.hdfs.DistributedFileSystem.initialize(
at org.apache.hadoop.fs.FileSystem.createFileSystem(
at org.apache.hadoop.fs.FileSystem.access$200(
at org.apache.hadoop.fs.FileSystem$Cache.get(
at org.apache.hadoop.fs.FileSystem.get(
at org.apache.hadoop.fs.FileSystem.get(
at projnewtest.hdfs_job_0_1.HDFS_JOB.tFileInputDelimited_1Process(
at projnewtest.hdfs_job_0_1.HDFS_JOB.runJobInTOS(
at projnewtest.hdfs_job_0_1.HDFS_JOB.main(
Caused by:
at Source)
at org.apache.hadoop.ipc.Client$Connection.receiveResponse(
at org.apache.hadoop.ipc.Client$
I have tried pinging the remote server , it works fine and am able to run commands using tSSH component, but am not able to use any of the hdfs components.All the hadoop processes are up and running on the server.
Is there some initial settings that I have missed out????
Community Manager

Re: Initial setting to connect to remote hadoop system

First, make sure you are able to connect to remote HDFS system with your ip and port. Execute the following command from CMD and see if it works.
dSmiley Embarassedtelnet ip port
I tested to put a file to HDFS with tHDFSPut in v.5.2.0 and it works, for detailed settings, please see my screenshots.
Talend | Data Agility for Modern Business

Re: Initial setting to connect to remote hadoop system

The port you are using is wrong. You are using the web port. The port for a namenode is 8020 or 9000 usually.
In order to get this port number, you can open the file core-site.xml in your hadoop configuration folder, and find the key "". You will get the namenode URI to put in your component.
I hope it helps,