Infobright: Wrong data or column definition

One Star

Infobright: Wrong data or column definition

Hey guys. I've got a problem specifically when using the tinfobrightoutput object. I'm pulling data from a modified apache log and when I do the load I get the following error from infobright
2010-10-19 15:52:37 The Infobright storage engine has encountered an unexpected error. The current transaction has been rolled back.
2010-10-19 15:52:37 Error: Wrong data or column definition. Row: 152271, field: 18.
2010-10-19 15:52:37 Error: An unknown system exception error caught.
I have checked this row of data and it appears to be the same as everything else. And I don't know how something unexpected could be passed to the loader as I'm not getting any errors from talend regarding the input that it's getting.
I was just wondering if anyone else has gotten this error while working with tinfobrightoutput.
- Peter
One Star

Re: Infobright: Wrong data or column definition

I want to add that I tried this process again, though the second time I had it output to a delimited file so I could see exactly what it was passing back to the infobright loader at line 152271 and in the csv file the data looks exactly as it should.
In this case the error message is coming from infobright, not from talend. There is something that Talend is sending to the infobright loader that it doesn't like. I don't think this is a problem with the format of the table or else the load would fail on the first record dues to data not being the correct type. I don't think this is a prblem with the log itself as it's being parsed correctly when I send it to a csv file.
I don't think the tmap would send something that's outside of it's scop (IE: I don't think that something in the output side of the tmap that is set to INT would pass a string to infobright) so I'm at a bit of a loss. While there is a distinct possibility that I might be doing something wrong, I am going to repost this to the bug forum as it sounds like that might be the case.
- Peter