How to upgrade Drools 5.2.0 for use with Java 1.7?

One Star

How to upgrade Drools 5.2.0 for use with Java 1.7?

Hi,
There's an issue with Drools on Java 7: Seam Drools fails on Java 7 with: value '1.7' is not a valid language level
How can I upgrade the version with respect to our Talend Platform for Data Services 5.2.2 installation?
Maybe with Archiva?
Thanks for any support.
br
Stefan
Moderator

Re: How to upgrade Drools 5.2.0 for use with Java 1.7?

Hi Stefan,
Let me consult and check with our developer that which version of Drools we are using in the new version of Talend Platform, we will come back to you asap!
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Employee

Re: How to upgrade Drools 5.2.0 for use with Java 1.7?

Hello stefan,
The version we have integrated is Drools 5.2.0.FINAL, in which the JDK version is restricted to 1.6 or previous. We are going to upgrade it in our futur versions.
Personally, I haven't tried to upgrade manually and don't know the consequences.
Instead of upgrading it manually, I suggest you to try the following workaround:
https://help.talend.com/search/all?query=trulesurvivorship&content-lang=en
This workaround is not for the same issue, but for the same root cause.
Regards,
Sizhao LIU
One Star

Re: How to upgrade Drools 5.2.0 for use with Java 1.7?

Hello,
Almost one year and several Talend releases since last answer in this thread.
Could you let us know what is the Drools version that comes shipped with Talend 5.5.0 ?