One Star

How to change the workspace path ?

Hello Everybody,
I would like to know how to change the workspace path ?

I have tried to add the commande line -data <workspace path>
For testing, I just copied my default workspace in c:\workspace
but when I launch TOS and that I select my project, I have an error in the loading of my job :

Une erreur interne s'est produite pendant : "L'initialisation du moteur de génération est en cours ...".
java.lang.NullPointerException

In English :
An internal error occurred during: "Initializing the generation engine is being ...".
java.lang.NullPointerException

Version of Talend :
Version: 3.1.1
Build id: r24830-20090518-1355
6 REPLIES
Community Manager

Re: How to change the workspace path ?

Hello
I tried to launch TOS3.1.1 and add param -data workspace and I don't get any problem. see screenshot
Best regards

shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: How to change the workspace path ?

me too but when i want to lauch a job, i have this error Smiley Sad
One Star

Re: How to change the workspace path ?

I am trying to put the same option -data in a desktop shortcut like this:
/opt/TOS_DI-r92826-V5.2.0/TOS_DI-linux-gtk-x86_64 -data /home/userdev/workspace-di5
but it makes an error (stacktrace in .log file ) "IllegalStateException"
Is that syntax works as well under Linux installation ?
I am under RedHat EL 6.2.
Thanks
Community Manager

Re: How to change the workspace path ?

I am trying to put the same option -data in a desktop shortcut like this:
/opt/TOS_DI-r92826-V5.2.0/TOS_DI-linux-gtk-x86_64 -data /home/userdev/workspace-di5
but it makes an error (stacktrace in .log file ) "IllegalStateException"
Is that syntax works as well under Linux installation ?
I am under RedHat EL 6.2.
Thanks

Hi
Does it works if you don't add -data parameter? As I seen, RedHat EL is not in the list of supported OS in prerequisites page.
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
Seventeen Stars

Re: How to change the workspace path ?

It works under Linux in this way! I use Linux only. (Debian 6)
One Star

Re: How to change the workspace path ?

Hi
Does it works if you don't add -data parameter? As I seen, RedHat EL is not in the list of supported OS in prerequisites page.
Shong

Yes, that's why I ask the question because I just copied the shortcut I usually use for launching the Studio from the gnome bar to the Desktop and add the -data parameter.
I also tried to put double quote for the path like this: -data "/home/userdev/myworkspacefolder" but it does the same error.
I found strange if it is supported under another linux distro but not in RHEL.
Otherwise, is it not possible to define the workspace in a specific .ini file and refer that .ini file from the shortcut? (I think eclipse should support that)
Thanks for support, if you need the .log file I can attach it here on request.
Patrick