One Star

Hosting a talend job as a webservice in Weblogic

I created a simple job in talend DI 5.1 which takes the input using the tbufferInput and sends the same values as output paramters.I exported this job as a Axis webservice WAR and tried to deploy it in weblogic 9.0 . The war got deployed , but when i went to the deployments , it did not list the webservice (saying no webservices available ), nor was i able to test the wsdl . Any information on how to host this talend job as a webservice will be highly appreciated ! TIA !
The war did successfully generate the wsdl . I have attached the job design . Would need inputs ASAP
5 REPLIES
Community Manager

Re: Hosting a talend job as a webservice in Weblogic

Hi
Here is a KB article shows how to deploy a Talend Job as a web service in Tomcat, but I think it should also work in weblogic, please follows the steps to deploy it and feedback to us.
https://help.talend.com/search/all?query=twebservice&content-lang=en
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: Hosting a talend job as a webservice in Weblogic

Hi, I came across this thread because of researching deploying war file in weblogic 12c. Above url is broken. Does anyone have idea how to deploy a Talend job as web service in Web Logic Server?

Thanks
Jane
Community Manager

Re: Hosting a talend job as a webservice in Weblogic

Hi Jane 
Deploying a DI job to tomcat or weblogic with Axis model has been deprecated. We have removed that article from THC, please use Talend Open Studio for ESB product to build the web service and deploy it to Talend runtime which is based on Apache karaf. 
Regards
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: Hosting a talend job as a webservice in Weblogic

Thanks Shong, so can I build the web service in Talend Open Studio for ESB and the deploy it on web logic??
One Star

Re: Hosting a talend job as a webservice in Weblogic

Hey Jane,
Could you resolve this issue?
I am facing exact same problem