Hbase Connectivity issue with Neo4j Database

One Star

Hbase Connectivity issue with Neo4j Database

Hi All,
I'm working on a Windows 7 64 bits and using TOS for Big Data 5.5
I created a new database using Neo4j 2.1.1
Hbase Version- hbase-0.94.8
hbase.zookeeper.quorum- "10.207.5.21"
hbase.zookeeper.clientPort - "2181
Job name : HbaseJobTest
I want to read from a hbase table to a Neo4j although I am getting a connection error. Here is my execution log:
Error Description :-
""Starting job HbaseJobTest at 11:11 17/06/2014.
Error: Could not find or load main class test.hbasejobtest_0_1.HbaseJobTest
Job HbaseJobTest ended at 11:11 17/06/2014. ""
PFA the image for connection arrangement.
So , would any one have an idea how to fix this issue? or
How may I use the tHBase* components to establish this?
Many Thanks
Sushil
Four Stars

Re: Hbase Connectivity issue with Neo4j Database

Hi,
I have faced this error many times, if the job building is not properly handled by talend. Re-executing the job fixed it autmatically... have you tried closing and opening it again?
Vaibhav
One Star

Re: Hbase Connectivity issue with Neo4j Database

Yes I have tried many times but still the problem is same.
One Star

Re: Hbase Connectivity issue with Neo4j Database

Now after re-executing so many time I'm getting error like

Starting job hbase_input_output at 13:53 17/06/2014.
java.lang.NoClassDefFoundError: projectname/hbase_input_output_0_1/hbase_input_output
Caused by: java.lang.ClassNotFoundException: projectname.hbase_input_output_0_1.hbase_input_output
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
Could not find the main class: projectname.hbase_input_output_0_1.hbase_input_output. Program will exit.
Exception in thread "main"
Job hbase_input_output ended at 13:53 17/06/2014.
Did you face the same ?? How can we resolve this issue ??
Thanks & Regards,
Sushil
One Star

Re: Hbase Connectivity issue with Neo4j Database

Are you using direct connection to Neo4j, if so try connect to Neo4j Rest API (server URL) instead, like the image.
http://lucidwebdreams.files.wordpress.com/2014/07/05_tneo4joutput.png

What’s New for Talend Spring ’19

Watch the recorded webinar!

Watch Now

Agile Data lakes & Analytics

Accelerate your data lake projects with an agile approach

Watch

Definitive Guide to Data Quality

Create systems and workflow to manage clean data ingestion and data transformation.

Download

Tutorial

Introduction to Talend Open Studio for Data Integration.

Watch