One Star

Getting error when trying to generate in job conductor

I get the following error with even the most basic usage of the tGoogleAnalyticsManagement component. I dont get this error when switching to the code tab in Talend and my job runs without error. Just when I try to generate in the job conductor, I get the following - any ideas? "PROFILE_NAME" seems fine in the code and again when using the same exact job design in the talend tool iteself, i get no error...Thanks!
java.lang.RuntimeException: org.talend.designer.runprocess.ProcessorException: Job compile errors
At least job "testgoog" has a compile errors, please fix and export again.
Error Line: 807
Detail Message: PROFILE_NAME cannot be resolved or is not a field
There may be some other errors caused by JVM compatibility. Make sure your JVM setup is similar to the studio.
    at org.talend.commandline.command.ExtensionCommandSwitch.caseExtensionServerCommand(ExtensionCommandSwitch.java:148)
    at org.talend.commandline.client.command.extension.AbstractExtensionCommandSwitch.doSwitch(AbstractExtensionCommandSwitch.java:31)
    at org.talend.commandline.command.CommandProcessorSwitch.caseExtensionCommand(CommandProcessorSwitch.java:161)
    at org.talend.commandline.client.util.CommandAbstractSwitch.doSwitch(CommandAbstractSwitch.java:70)
    at org.talend.commandline.command.CommandConsumer.executeCommand(CommandConsumer.java:57)
    at org.talend.commandline.command.CommandConsumer.execute(CommandConsumer.java:35)
    at org.talend.commandline.mode.ServerCommandLine$CommmandConsumerRunnable.run(ServerCommandLine.java:139)
    at java.lang.Thread.run(Unknown Source)
Caused by: org.talend.designer.runprocess.ProcessorException: Job compile errors
At least job "testgoog" has a compile errors, please fix and export again.
Error Line: 807
Detail Message: PROFILE_NAME cannot be resolved or is not a field
There may be some other errors caused by JVM compatibility. Make sure your JVM setup is similar to the studio.
    at org.talend.designer.runprocess.JobErrorsChecker.checkLastGenerationHasCompilationError(JobErrorsChecker.java:281)
    at org.talend.commandline.util.JobHandler.export(JobHandler.java:237)
    at org.talend.commandline.command.execute.BuildJobExecuteCommand.execute(BuildJobExecuteCommand.java:109)
    at org.talend.commandline.command.ExtensionCommandSwitch.caseExtensionServerCommand(ExtensionCommandSwitch.java:146)
    ... 7 more
7 REPLIES
Moderator

Re: Getting error when trying to generate in job conductor

Hi barkawiamet,

On which official version did you get that? Are you using the Studio and CommandLine on different machines?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Getting error when trying to generate in job conductor

We are using the talend platform version. Full blown with 5 licenses. Latest version. The command line and studio are on the same machine.
One Star

Re: Getting error when trying to generate in job conductor

looks like Talend Platform for Data Management - v5.6.1.20141207_1530
all on a single server.
Community Manager

Re: Getting error when trying to generate in job conductor

Hi
Was it an existing Job using this tGoogleAnalyticsManagement component that you migrated to v5.6?
There seems to be a disclaimer by CIMT on the Talend Exchange regarding a new schema definition which requires the component to be removed and added again to a Job: Talend_Exchange/tGoogleAnalyticsManagement
Not sure this is related, but just in case. Also, as you're a Talend Customer, I strongly advise that you contact the Customer Support to get direct help.
Cheers,
Elisa
One Star

Re: Getting error when trying to generate in job conductor

Hi, we are using the latest version of the component and have been only using that version. On the site it said to use this forum for support on the component and since it is not a Talend created widget, we didn't think that support would be able to assist really. But, if that's a possibility, we will give it a go. Thanks
One Star

Re: Getting error when trying to generate in job conductor

In case anyone else has this problem - we figured it out. Turns out the command line component path was not set to the directory where the components used in the particular job design were located. Once this was fixed, the job was able to build without a problem. Thanks.
Four Stars

Re: Getting error when trying to generate in job conductor

there is a compilation in your job. fix that and try to build the job