Five Stars

Getting error when enabling parallel execution

I am setting my job as,

Capture.JPG

In the above image i have enabled Eable Parallel Execution checkbox

Now it is getting following error...

Capture1.JPG

 

Please provide the solution for this....

 

Thanks in advance,

Abhi529

 

  • Data Integration
6 REPLIES
Six Stars sgv
Six Stars

Re: Getting error when enabling parallel execution

Hi,

 

did you active the multi thread execution un job setting ?

 

Capture.PNG

 

SGV

Five Stars

Re: Getting error when enabling parallel execution

Hello SGV,

I have enabled that option and re executed the job then also  i am getting same error..

Thanks,

Abhi529

Six Stars sgv
Six Stars

Re: Getting error when enabling parallel execution

It's working for me ... thanks, now I know that we can multi thread with iterate ! =)

For you, I think a librarie is missing... but wich one ?  >_<

 

C:\Talend\TOS_DI-Win32-20151029_1337-V6.1.0\plugins\org.talend.librariesmanager_6.1.0.20151029_1337\resources\java\routines\system

you have a TalendThreadPool.java.

 

If you don't find then .java, then you have to install module (normally the component ask you to install the missing lib).

Maybe shake on Modules view if lib is missing

 

Good luck

SGV

 

Five Stars

Re: Getting error when enabling parallel execution

Hi sgv,

I have TalendThreadPool.java in the path:

C:\Talend\6.1.1\studio\plugins\org.talend.librariesmanager_6.1.1.20151214_1327\resources\java\routines\system

you can find that file in the attachment

still i did not got the required result..

 

Abhi529 

 

Six Stars sgv
Six Stars

Re: Getting error when enabling parallel execution

Don't understand where is the problem ...

 

Can you try something, and it's my last card ^^

in   C:\Talend\TOS_DI-Win32-20151029_1337-V6.1.0\plugins

you probably have a  "org.talend.librariesmanager.ui_6.1.0.2015029_1337.jar"

Or something like that.
Try to use tLibraryLoad at begining of your job and add this file....

Good luck,

SGV

 

 

Five Stars

Re: Getting error when enabling parallel execution

Hi sgv,

now it is working fine ..

Thanks,

Abhi529