Getting Error When Running Job using tMSSqlSP Component

Four Stars

Getting Error When Running Job using tMSSqlSP Component

Recently, I updated my OS to Windows 10 64-Bit, installed TOS DI V7.0.1 and Java JDK 1.8.0_77 based on the installation document suggestion. I have followed all of the instruction mentioned inside the document which includes to set JAVA_HOME and to edit the project's preferences.

After I import my existing job from TOS DI V5.5, I faced the following error in running some job using tMSSqlSP component which is used to execute sql function or store procedure (passing parameter using date type).

 

java.lang.VerifyError: Inconsistent stackmap frames at branch target 3792
Exception Details:
  Location:
    ppctmigration/setupexchangerate_0_1/SetupExchangeRate.tFileInputExcel_1Process(Ljava/util/Map;)V @3792: ldc_w
  Reason:
    Type top (current frame, locals[28]) is not assignable to 'java/sql/Timestamp' (stack map, locals[28])
  ..........................
  ..........................
  ..........................
	at java.lang.Class.getDeclaredMethods0(Native Method)
	at java.lang.Class.privateGetDeclaredMethods(Class.java:2701)
	at java.lang.Class.privateGetMethodRecursive(Class.java:3048)
	at java.lang.Class.getMethod0(Class.java:3018)
	at java.lang.Class.getMethod(Class.java:1784)
	at sun.launcher.LauncherHelper.validateMainClass(LauncherHelper.java:544)
	at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:526)
Error: A JNI error has occurred, please check your installation and try again
Exception in thread "main" 

 

I have found similar thread like

I have tried all of them but they're not really working. Do you have any idea to help solve this issue?

Appreciate if I could hear from you soon.

Regards,

Jimmy

 

Moderator

Re: Getting Error When Running Job using tMSSqlSP Component

Hello Jimmy,

Regarding to the error, it's a bug of jdk1.7 & jdk1.8
http://bugs.java.com/bugdatabase/view_bug.do?bug_id=8067429

Have you tried to use other JDK version (e.g. jdk1.8.0_45 or jdk1.8.0_131) to see if it works?

Are you able tp use the '-noVerify' JVM argument in your production environment to avoid java.lang.VerifyError?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Four Stars

Re: Getting Error When Running Job using tMSSqlSP Component

Hello Sabrina,

I have tried using JDK version jdk1.8.0_131, unfortunately the error is still occur.

 

I assume the problem laid in using tMap & tMSSqlSP. I tried to replace tMap with tJavaRow, it's working in JDK version jdk1.8.0_192.
But the problem now is that, I have several job required to used tMap component along with tMSSqlSP. Is there any chance that it's cause of .jar library?

 

Best Regards,

Jimmy

2019 GARNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

Best Practices for Using Context Variables with Talend – Part 1

Learn how to do cool things with Context Variables

Blog

Migrate Data from one Database to another with one Job using the Dynamic Schema

Find out how to migrate from one database to another using the Dynamic schema

Blog

Best Practices for Using Context Variables with Talend – Part 4

Pick up some tips and tricks with Context Variables

Blog