Four Stars

GSS initiate failed when trying to connect to Kerborose enabled cloudera cluster.

Hi ,

 

I am trying to connect to Hive server from talend but I amd getting below error. I am using kerberos authentication here. But I tested the same with PuTTY and I am able to connect successfully.

 

Could you please help me here..

 

Connection failure. You must change the Database Settings.
java.sql.SQLException: java.util.concurrent.ExecutionException: java.sql.SQLException: Could not open client transport with JDBC Uri: jdbc:hive2://localhost:10000/default;principal=hive/localhost@HADOOP-QA-CLIENT.MA: GSS initiate failed
at org.talend.metadata.managment.connection.manager.HiveConnectionManager.createHive2StandaloneConnection(HiveConnectionManager.java:280)

4 REPLIES
Moderator

Re: GSS initiate failed when trying to connect to Kerborose enabled cloudera cluster.

Hello,

Please let us know if this article about:https://community.talend.com/t5/Migration-Configuration-and/Hive-Connection-to-Kerberized-cluster/ta... is OK with you.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Four Stars

Re: GSS initiate failed when trying to connect to Kerborose enabled cloudera cluster.

Hi Sabrina,

 

I have tried with provided solution,unfortunately it didn't solve the issue. I am attaching the connection details and error details please check and help us to resolve in this issue.

 

Thanks&Regards,

Hari

 

 

Four Stars

Re: GSS initiate failed when trying to connect to Kerborose enabled cloudera cluster.

Team ,Can you please help me to sort out this issue.

Four Stars

Re: GSS initiate failed when trying to connect to Kerborose enabled cloudera cluster.

Can some one reply on Issue