One Star dee
One Star

For input string: "null"

Hi
I have a Talend job that works seemingly perfectly except for this red text:
For input string: "null"
For input string: "null"
For input string: "null"
For input string: "null"
For input string: "null"
For input string: "null"
For input string: "null"
For input string: "null"
For input string: "null" etc
I have taken a CSV file and filtered it before placing the data in a table. How do I get rid of this red text? Or it is ok?
7 REPLIES
Moderator

Re: For input string: "null"

Hi,
How did you set your input schema? The "null" string must be rejected by tfileinputxxx component according to your schema setting. You can set your schema data type as "String" without checking.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star dee
One Star

Re: For input string: "null"

Hi Sabrina,
I have no idea how I set my input schema... where do I find that out? How do I reject the null string? And how do I set the data type without checking?
I'm obviously very new to all this...
One Star dee
One Star

Re: For input string: "null"

I realised I can make it not null in the schema setting. Is that was you meant? So I did that but I still have the same problem...
Moderator

Re: For input string: "null"

Hi,
To make it clear, I have designed a demo job for you.
I have input file:
id;name
null;elise
2;shong
3;sabrina
There is "null" string in it. You will get the info "For input string: "null", if you set the id column as "Int"(see my pic1, pic 2 )
You can set your schema data type as "String" without checking( it is not rejected by tfileinputxxx component, see my pic 3,4)
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star dee
One Star

Re: For input string: "null"

Awesome. I appreciate that effort to help me.
So I just change my int to String?
I did that and that issue is gone but then i get this:
Incorrect integer value: 'null' for column 'ID' at row 10
One Star dee
One Star

Re: For input string: "null"

Oh... nevermind. I see in the file there isn't a number but rather the word "null"...
Moderator

Re: For input string: "null"

Hi,
Talend offers a rich set of online and instructor-led training courses to speed your ramp-up time, deliver projects faster, and maximize your Talend investment.
You can have a look at it http://www.talend.com/services/training.
Feel free post your issue on forum.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.