Execution failed :generationManager is not initialized by the perljet/

One Star

Execution failed :generationManager is not initialized by the perljet/

I have a machine that I've been successfully developing several Talend TOS DI jobs on. Today, out of the blue, it will no longer execute any jobs. I get:
Execution failed :generationManager is not initialized by the perljet/javajet!
In the console.
I saw this reported in the bug tracker, and closed as could not duplicate. I do not know how to duplicate this as I don't know what is causing it in the first place. I had to move all of my jobs onto another machine to be able to work on them.
What could I do to troubleshoot this problem? This is the second machine I've worked on that would not run Talend jobs. Fixing the first required an OS reload (never mind that everything else worked find). Reloading the OS on this machine is not an option.
Windows server, TOS DI 5.0.2.478327
Java 1.6.0_31
The other machine that stopped running Talend jobs was a 64 bit Slackware 13.37 machine (linux).
One Star

Re: Execution failed :generationManager is not initialized by the perljet/

Hi
Have you ever added some custom components?
Usually it's hard to reproduce this issue and there isn't an accurate way to fix it.
Try to delete 'ComponentsCache.javacache' under <TOS Installation dir>\configuration and restart TOS.

Regards,
Pedro

What’s New for Talend Spring ’19

Join us live for a sneak peek!

Sign up now

Agile Data lakes & Analytics

Accelerate your data lake projects with an agile approach

Watch

Definitive Guide to Data Quality

Create systems and workflow to manage clean data ingestion and data transformation.

Download

Tutorial

Introduction to Talend Open Studio for Data Integration.

Watch