Error with Metadata Crawler

Four Stars

Error with Metadata Crawler

Hello

I am using TOS 6.3.1 with the metadata crawler workspace for TOS 6.x. My metadata crawling run crashed with the following error message:

 

Ausführung fehlgeschlagen: Job compile errors
At least job "scan_map_qgis" has a compile errors, please fix and export again.
Error Line: 21184
Detail Message: root_12_0_1_tAFOX_3 cannot be resolved to a variable

There may be some other errors caused by JVM compatibility. Make sure your JVM setup is similar to the studio.

 

I am aware that the last line is a kind of default message I get after all errors (see https://community.talend.com/t5/Design-and-Development/Getting-error-JVM-setup-is-similar-to-the-stu...). Is there anything wrong with my installed JRE's (see screenshot below)?

 

installed_JREs.pngInstalled JREs

Other questions: I'd like to check the code but where do I find 'line 21184'? Has anyone an idea what 'root_12_0_1_tAFOX_3' could mean or come from?

Six Stars

Re: Error with Metadata Crawler

Hi @ckampichler, you can find the source code under: https://github.com/talend-spatial/workspace-metadata-crawler

Hope it helps to debug the error.

- JG
Moderator

Re: Error with Metadata Crawler

Hello,

So far, talend don't support for openJDK. Have you tried to use oracle JDK 1.8 to see if your job works?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Four Stars

Re: Error with Metadata Crawler

Hi,

I installed the oracle JDK 1.8 as suggested by @xdshi but the error remains the same.

Since the error occurred in scan_map_qgis 0.1 I also tried to scan a raster file with scan_raster 0.1 instead of using run 0.1 . At first sight, this seems to work without error (except about the PNG driver):

Starte Job scan_raster am 15:53 06/06/2017.

[statistics] connecting to socket on port 3821
[statistics] connected
2017-06-06 15:53:05|DdRVvg|DdRVvg|DdRVvg|METADATA_CRAWLER|scan_raster|test|3|tWarn|tWarn_4|# Analyzing raster datasource : /media/data/Geodata_Test/openheid2009_mean.asc|0
2017-06-06 15:53:05|kvq80X|DdRVvg|DdRVvg|METADATA_CRAWLER|generateRasterOverview|Default|3|tWarn|tWarn_2|## Creating overview for  : /media/data/Geodata_Test/openheid2009_mean.asc|0
Input file size is 280, 325
0...10...20...30...40...50...60...70...80...90...100 - done.
2017-06-06 15:53:05|kvq80X|DdRVvg|DdRVvg|METADATA_CRAWLER|generateRasterOverview|Default|5|tWarn|tWarn_1|Error generating TIF overview for vector file :/media/data/Geodata_Test/openheid2009_mean.asc 
 Error message : Warning 6: PNG driver doesn't support data type Float32. Only eight bit (Byte) and sixteen bit (UInt16) bands supported. Defaulting to Byte
|0
2017-06-06 15:53:05|kvq80X|DdRVvg|DdRVvg|METADATA_CRAWLER|generateRasterOverview|Default|3|tWarn|tWarn_3|## Overview created  : /media/data/Geodata_Test/openheid2009_mean.asc_overview.png|0
2017-06-06 15:53:05|9BWG7B|DdRVvg|DdRVvg|METADATA_CRAWLER|pack_data|Default|3|tWarn|tWarn_1|Packing data: /media/data/Geodata_Test/openheid2009_mean.asc layers: raster...|0
2017-06-06 15:53:05|9BWG7B|DdRVvg|DdRVvg|METADATA_CRAWLER|pack_data|Default|3|tWarn|tWarn_2|Creating archive: openheid2009_mean.asc.zip in /tmp/scan/download/ (all files matching: 'openheid2009_mean.*' in '/media/data/Geodata_Test' will be included in the archive) ...|0
2017-06-06 15:53:05|DdRVvg|DdRVvg|DdRVvg|METADATA_CRAWLER|scan_raster|test|3|tWarn|tWarn_5|### Metadata record /media/data/Geodata_Test/openheid2009_mean.asc_md_iso19139-.xml created for :  /media/data/Geodata_Test/openheid2009_mean.asc|0
[statistics] disconnected
Job scan_raster endet am 15:53 06/06/2017. [exit code=0]

The overview png is produced without problems, but the metadata xml-file is empty (0 bytes).

I tried also to scan a shape file with run_vector 0.1, but with the same result: the two xml-files (iso19110 and iso19139) are generated but are empty.

Any hints?

Christian

What’s New for Talend Spring ’19

Watch the recorded webinar!

Watch Now

Agile Data lakes & Analytics

Accelerate your data lake projects with an agile approach

Watch

Definitive Guide to Data Quality

Create systems and workflow to manage clean data ingestion and data transformation.

Download

Tutorial

Introduction to Talend Open Studio for Data Integration.

Watch