Error while building job

One Star

Error while building job

I am getting an error while trying to do build job for a simple job i created that loads a file to a table. The Job executes just fine from the open studio.
I am using Talend Open Studio Version: 6.2.1
I am on Windows 8.1 64 bit
JDK version installed on machine: jdk 1.8.0_91, jre 1.8.0_91
While building... I changed the default Archive file location to a folder of my preference.
Build Type: Standalone Job
All options defaulted/checked (except apply context to child jobs, because its N/A for me).
Additional info:
I tried creating for Windows or Unix alone too, getting same error.
I am getting this exactly when the build job runs past the "setting classpath containers step".
I have attached the screenshots and also the .log file from my workspace
Below is the error am getting. 
va.lang.Exception: Job was not built successfully, please check the logs for more details
at org.talend.repository.ui.wizards.exportjob.scriptsmanager.BuildJobManager.buildJob(BuildJobManager.java:252)
at org.talend.repository.ui.wizards.exportjob.scriptsmanager.BuildJobManager.buildJob(BuildJobManager.java:162)
at org.talend.repository.ui.wizards.exportjob.scriptsmanager.BuildJobManager.buildJobs(BuildJobManager.java:104)
at org.talend.repository.ui.wizards.exportjob.JobScriptsExportWizardPage.buildJobWithMaven(JobScriptsExportWizardPage.java:1483)
at org.talend.repository.ui.wizards.exportjob.JobScriptsExportWizardPage$8.run(JobScriptsExportWizardPage.java:1388)
at org.eclipse.jface.operation.ModalContext.runInCurrentThread(ModalContext.java:466)
at org.eclipse.jface.operation.ModalContext.run(ModalContext.java:374)
at org.eclipse.jface.wizard.WizardDialog.run(WizardDialog.java:1059)
at org.talend.repository.ui.wizards.exportjob.JobScriptsExportWizardPage.finish(JobScriptsExportWizardPage.java:1393)
at org.talend.repository.ui.wizards.exportjob.JavaJobScriptsExportWSWizardPage.finish(JavaJobScriptsExportWSWizardPage.java:1225)
at org.talend.repository.ui.wizards.exportjob.JobScriptsExportWizard.performFinish(JobScriptsExportWizard.java:126)
at org.eclipse.jface.wizard.WizardDialog.finishPressed(WizardDialog.java:853)
at org.eclipse.jface.wizard.WizardDialog.buttonPressed(WizardDialog.java:438)
at org.eclipse.jface.dialogs.Dialog$2.widgetSelected(Dialog.java:619)
at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:248)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4353)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1061)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4172)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3761)
at org.eclipse.jface.window.Window.runEventLoop(Window.java:832)
at org.eclipse.jface.window.Window.open(Window.java:808)
at org.talend.repository.ui.actions.ExportJobScriptAction.doRun(ExportJobScriptAction.java:117)
at org.talend.repository.ui.actions.AContextualAction$2.run(AContextualAction.java:632)
at org.talend.repository.RepositoryWorkUnit.executeRun(RepositoryWorkUnit.java:99)
at org.talend.core.repository.model.AbstractRepositoryFactory.executeRepositoryWorkUnit(AbstractRepositoryFactory.java:258)
at org.talend.repository.localprovider.model.LocalRepositoryFactory.executeRepositoryWorkUnit(LocalRepositoryFactory.java:3257)
at org.talend.core.repository.model.ProxyRepositoryFactory.executeRepositoryWorkUnit(ProxyRepositoryFactory.java:2053)
at org.talend.repository.ui.actions.AContextualAction.run(AContextualAction.java:641)
at org.eclipse.jface.action.Action.runWithEvent(Action.java:519)
at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:595)
at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:511)
at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(ActionContributionItem.java:420)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4353)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1061)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4172)
.log.log
Moderator

Re: Error while building job

Hi,
Could you please use jdk 1.8.0_5 instead to see if it works well?
We got some problems when use jre 1.8.0_92.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Error while building job

I am having a similar issue. When will this be addressed? Unfortunately jdk 1.8.0_5 is not an option for me.
TIA
Ken
One Star

Re: Error while building job

I tried after installing jdk1.8.0_5 and still got the same error.
After installing jdk 1.8.0_5, i then changed Windows -> Preferences -> Java -> Jre -> ./...../jdk1.8.0_5/
And then tried closing the app, reopening, verifying preferences once again to make sure and then tried doing a build. Still got same error.
Anything else i can try?
 
Moderator

Re: Error while building job

Hi,
Does this issue repro on all your jobs or just a specific job? 
We can't see the screenshot on our side. Could you attach it on the forum, please? That would be great.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Error while building job

This is happening for any job. These are my initial attempts to build jobs.
I am attaching the screenshot/log files using Upload feture. Letsee if you can see it.
(What did you mean by attach it on the forum, exactly? is there a different way than attaching it just during the reply)
Moderator

Re: Error while building job

Hi,
We cannot repro your issue on V 6.2.1,Window10.
Have you tried to reinstall your studio to see if it works? Did you set up your java environment correctly?
https://help.talend.com/search/all?query=Java&content-lang=en
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Error while building job

I was finally able to get through this problem after reinstalling.
First time when i installed, there were some error and i skipped some of them.
Now during reinstallation i paid attention to those errors and obbserved that they were due to longer path name.
So I reinstalled/extracted in just C:/talend folder. Now all is well. Installation/extraction did not have any errors and also no errors while building.
Thank you all for the help.
Moderator

Re: Error while building job

Hi,
Thanks for your feedback and sharing your solution here.
Could you please mark this topic as resolved?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.