Six Stars

Error when trying to created a File delimited Metadata

I am new to Talend and I am trying to make a file delimited Metadata and I am getting the below error. The file I am using is tab delimited text file which I copied and pasted out of my SQL data base for this test.

 

Error: Could not find or load main class local_project.shadowfileinputtodelimitedoutput_0_1.ShadowFileInputToDelimitedOutput

Preview error. Some settings must be changed.
Note: Preview errors are generally due to a wrong encoding setting.
org.talend.designer.runprocess.shadow.ShadowFilePreview.preview(ShadowFilePreview.java:90)
org.talend.metadata.managment.ui.utils.ShadowProcessHelper.getCsvArray(ShadowProcessHelper.java:383)
org.talend.repository.ui.wizards.metadata.connection.files.delimited.DelimitedFileStep2Form$PreviewProcessor.nonUIProcessInThread(DelimitedFileStep2Form.java:1309)
org.talend.commons.ui.swt.thread.SWTUIThreadProcessor$1.run(SWTUIThreadProcessor.java:74)

 

I have the newest Java installed 6.4.0 of Talend installed.

 

I have 2 screen shots attached.

1 ACCEPTED SOLUTION

Accepted Solutions
Six Stars

Re: Error when trying to created a File delimited Metadata

I was able to resolve this. It was the fact that I had installed the application in the Program Files directory and it didn't like the space in the folder name. Once I moved the install directory everything worked correctly.

2 REPLIES
Employee

Re: Error when trying to created a File delimited Metadata

Did you download the mandatory third party libraries?  Also, talend generates java code that it executes.  Here you can see the class is local_project.shadowfileinputtodelimitedoutput_0_1.ShadowFileInputToDelimitedOutput

Do you have antivirus preventing the generation of this java file?  

 

Can you try this out with Talend 6.3.1 instead of 6.4.0 and let us know if it works?  

Six Stars

Re: Error when trying to created a File delimited Metadata

I was able to resolve this. It was the fact that I had installed the application in the Program Files directory and it didn't like the space in the folder name. Once I moved the install directory everything worked correctly.