Error: "TLS 1.0 has been disabled in this organization. Please use TLS 1.1 or higher"

Talend Version          6.x

Summary

Issue with the tSalesforceConnection component when connecting to a Salesforce server.
Additional Versions 5.6.x
Key words tSalesforceConnection TLS
Product  
Component  
Article Type  
Problem Description

The following exception is thrown from tSalesforce* components:

Exception in component tSalesforceConnection_1
com.salesforce.soap.partner.UnexpectedErrorFault: UNSUPPORTED_CLIENT: TLS 1.0 has been disabled in this organization. 
Please use TLS 1.1 or higher when connecting to Salesforce using https.
Problem root cause The following link is a Salesforce announcement that they are disabling the TLS 1.0 encryption protocol: Salesforce disabling TLS 1.0
Solution or Workaround

Talend version 6.x supports Java 1.8.

Ensure you run the Job with JVM version 1.8.

 

Alternatively, for previous versions of Talend that support Java 1.7, ensure you run the Job with the latest update of Java 1.7 and with the following Java system property:

-Dhttps.protocols=TLSv1.1,TLSv1.2 
JIRA ticket number TDI-33392
Version history
Revision #:
5 of 5
Last update:
‎07-13-2017 03:27 PM
Updated by:
 
Labels (2)
Contributors
Tags (2)