Four Stars

Error in tfileoutputdelimited.

Hi All,

 

I am trying to create pipeline separated .mnt file, as my data contains arabic language in one of the column ,1 line is spliting into 2 lines.

 

Please find attached screen shot for mapping 

As i am unable to attach .mnt file here i just saved the same as .txt file and attached

 

Kindly anyone help me on the same.

 

 

 

4 REPLIES
Moderator

Re: Error in tfileoutputdelimited.

Hello,

Are you looking for "Split output in several files" option in advanced settings of tfileoutputdelimited component?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Twelve Stars TRF
Twelve Stars

Re: Error in tfileoutputdelimited.

Hi,

As soon as you have records splitted on several lines, they must be enclosed (usually) by " else you will be unable to decide where the records finish.

For that, go to advanced setting then tick the option "CSV options" (" is the default for text enclosure).

 

Does this helps?


TRF
Four Stars

Re: Error in tfileoutputdelimited.

Hi Sabrina,

 

I am not trying to write it into different file,i need the entire data in single file.

 

Thanks,

Padmini. 

Four Stars

Re: Error in tfileoutputdelimited.

Hi TRF,

 

Thanks for the reply, i tried as you mentioned but still the issue persists,please find attached txt file for the same.

 

First 2 records are in correct as there is no any Arabic data, but in my third record as it contains  arabic language its jumping up to next line.

 

Thanks,

Padmini.