One Star

Error in component tOracleSCD - Unknown value in the list

Hello everybody,
when trying to update a table i keep getting this error on the tOracleSCD component.
I already set the length of each field on the table schema to a specified value (20 for Integers, 50 for Strings) just to be sure there are no zero-length fields that can cause the problem.
I'll be grateful for any kind of help or hint,
thank you very much.
Jacopo
14 REPLIES
One Star

Re: Error in component tOracleSCD - Unknown value in the list

Hi Jacopo
Do you get a warning as Image 1?
If so, please click "Code" tag and show us the error line.
A screenshot is preferred.
Then continue running the job. Do you get some new errors?
Or send me an email and attach the archive file of this export job. I will test it for you.
Regards,
Pedro
One Star

Re: Error in component tOracleSCD - Unknown value in the list

Hello pedro,
the error message I get is the same that you showed me.

When I switch to the code tab I cannot see where the error is located, there are no red dots signaling an error.

This is the view showing the output of a tMap component synchronized to the schema of the tOracleSCD component, every field has a length.

And finally this is the SCD editor. It's a fairly easy update, I have a single key (numero) and i have to check all other fields for a type 1 SCD update.
One Star

Re: Error in component tOracleSCD - Unknown value in the list

>> Then continue running the job. Do you get some new errors?
I don't get any new error, the job finishes but the trace going to the SCD component shows 0 records updated.
One Star

Re: Error in component tOracleSCD - Unknown value in the list

This is the end of the Job Run.
One Star

Re: Error in component tOracleSCD - Unknown value in the list

Hi
Which version of TOS do you use?
I reproduce the same issue in TOS 5.0.0, TOS5.0.2, TOS5.1.0.
But in TOS4.2.0 it works fine.
Please report it on BugTracker.
Regards,
Pedro
One Star

Re: Error in component tOracleSCD - Unknown value in the list

So it's a bug, I'm actually using TOS 5.0.2.
I have TOS 4.1 installed, should I try to export the job and import it there?
Thaks
One Star

Re: Error in component tOracleSCD - Unknown value in the list

Hi
Now it seems that you have to recreate this job in TOS4.1.
Because TOS doesn't support migrating job from new version to old version.
Regards,
Pedro
One Star

Re: Error in component tOracleSCD - Unknown value in the list

I created the entry on bugtracker, details here: http://jira.talendforge.org/browse/TDI-20675
The fact that I cannot import the job in a previous version of Talend is a really bad news for me, cause the job is a bit complex and I'll have to recreate lots of Metadata.
At least we isolated the problem.
Thank you for your help and support
Jacopo
One Star

Re: Error in component tOracleSCD - Unknown value in the list

Hi Jacopo
Thanks for your feedback.
The same bug also exists in tPostgresqlSCD.
Regards,
Pedro
One Star

Re: Error in component tOracleSCD - Unknown value in the list

Hi guys,
The same error is in the tVtigerCRMOutput component.
One Star

Re: Error in component tOracleSCD - Unknown value in the list

Hi,
Is a fix planned ?
One Star

Re: Error in component tOracleSCD - Unknown value in the list

Hi Simon
It is still unresolved.
Here is the URL for this issue on JIRA.
http://jira.talendforge.org/browse/TDI-20675
Regards,
Pedro
One Star

Re: Error in component tOracleSCD - Unknown value in the list

Hi,
I still can't login using my issurface account to the forum. Anyhow, can anyone please advise the resolution for this? We're trying to migrate from Talend 4 to Talend 5. Our jobs using toraclescd in talend 4 with autoincrement which is working fine in talend 4 but when we migrate to talend 5.3.1 it giving us that error
Unknown value in the list / Value set not supported by the component
our license expired in 2 weeks, appreciate a quick response.
Thank you.
Regards,
Rera
Moderator

Re: Error in component tOracleSCD - Unknown value in the list

Hi Rera,
For your login issue, did you try to clear your cache of browse to see if it is Ok with you?

For your migration issue, did you use Talend Enterprise Subscription Version? If so, you'd better open ticket on Talend Support Portal so that our colleagues from support team can schedule a webex with you to give a remote assistance.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.