One Star

Encountered code generation error while compiling script: generated b

Hi,
We are trying to run a job in prod through TAC. we are receiving the below error.
"Exception in component tFileInputJSON_2
javax.script.ScriptException: sun.org.mozilla.javascript.EvaluatorException: Encountered code generation error while compiling script: generated bytecode for method exceeds 64K limit."
.
The same job is running in QA from TAC and able to run in TOS as well. But the problem occurs in prod only.
Please suggest..
Regards
Govardhan
4 REPLIES
Moderator

Re: Encountered code generation error while compiling script: generated b

Hi govardhant85,
Could you please report a ticket on Talend Support Portal so that we can give you a remote assistance to address your issue with priority, through the support cycle.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Encountered code generation error while compiling script: generated b

Hi,
Thanks for the prompt response.
Its not possible for me to raise a ticket as i am new to this project. Yet to get the more details.
Is it possible to share with me, what to check and all. Also if you have a work around can you please suggest.
Regards
Govardhan
Moderator

Re: Encountered code generation error while compiling script: generated b

Hi,
"Exception in component tFileInputJSON_2
javax.script.ScriptException: sun.org.mozilla.javascript.EvaluatorException: Encountered code generation error while compiling script: generated bytecode for method exceeds 64K limit."
.

This issue is probably caused by a big json file. Could you please have a look at jira issue https://jira.talendforge.org/browse/TDI-24813?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Encountered code generation error while compiling script: generated b

Hi,
I have checked a simple job with >3MB data json file. It seem to be not an issue with the json file.
Like i mentioned, the job is running fine in QA TAC environment.
Are there any settings that need to be checked.
Regards
Govardhan