One Star

Display/Resolution problems with Open Studio for ESB

Hi all,
I'm a Talend newbie, and I just installed Talend Open Studio for ESB.  I'm running Windows 8.1.  After setting JAVA_HOME, I launched the IDE.  It loaded up successfully, but I quickly noticed that the overall display looked "wonky".  What I mean by that is:

    1.  The resolution of certain areas on the screen was really small.  For example, the menu buttons at the top are so small they're hard to see.



    2.  Some of the tabs were partially hidden


    3.  Some of the checkboxes were cut off

                              
Has anyone run into this sort of thing before?

Thanks,
Chris                                             
7 REPLIES
One Star

Re: Display/Resolution problems with Open Studio for ESB

By the way, I included screenshots in my original post, however for some reason they do not show up....
One Star

Re: Display/Resolution problems with Open Studio for ESB

After a lot of googling, I suspect that this is a graphics display scaling issue that has troubled applications running on high-DPI platforms.  I'm running a Dell XPS 15 using 3840 x 2160 resolution.  I further suspect that the problem resides in the underlying Eclipse platform, which was originally described here:
I wish I could embed screenshots of my Talend UI, but I think my low post count prevents me.
I've tried a number of things to fix the display/layout issues, including:
1.  Lowering resolution
2.  Running Talend OpenStudio in Windows 7 Compatibility mode
3.  Modifying the text size via Control Panel => Display
...but nothing has really helped.
Does this ring any bells for anyone?
One Star

Re: Display/Resolution problems with Open Studio for ESB

I have similar issues with Talend Big data studio, where Icons are very small and hardly visible
One Star

Re: Display/Resolution problems with Open Studio for ESB

 screen shot attached
Five Stars

Re: Display/Resolution problems with Open Studio for ESB

Hi,
Bumping this thread, anyone has a fix for this already? 
Pretty unusable on my Surface Book Smiley Sad
Regards,
V
One Star

Re: Display/Resolution problems with Open Studio for ESB

I have the same problem. Talend Open Studio is close to unusable for me because of this problem. I tried to fix it by enlarging all icons as described here, . It helped to some degree, but toolbars and rows are still not fully visible.
I found this uncommented ticket, . Seems like Talends base on an old version of Eclipse is the problem.
One Star

Re: Display/Resolution problems with Open Studio for ESB

Sorry, the links was stripped from the message.
I was referring to ticket EXCHANGE-148 in Jira at Talendforge, and davidglevy's eclipse-icon-enlarger at GitHub.