Deploying a job jar causes the same error

One Star

Deploying a job jar causes the same error

Hi All. 

   I am new to Talend. I am having an issue here. 

   I import a job into Talend, and then I edited its version and built it again. I uploaded the jar file to the maven repository. Then I called the job with the new version in the java code, I will get the error 

The hash is not initialized : The hash must exist before you read from it"

   I want to point it out is that I just edited the version and didn't touch the job itself at all. There is no any change made in the original job. After deploying the job jar in java, I will get this runtime exceptions. 

 

   Also if I do add a change, any change, it results the same error. 

   Or if I duplicate the job and change to another name, it results the same error. 

   Only the current version works fine,  therefore, I am not able to add any new component to job  as the job will fail on the same component no matter what. 

    I have been stuck for a couple of days. Can everyone  provide any suggestions or insights?

 

    Thank you so much. 

Employee

Re: Deploying a job jar causes the same error

can u share you job? Export the job and attached here.

2019 GARNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

An API-First Approach to Modernizing Applications

Learn how to use an API-First Approach to Modernize your Applications

Watch Now

Talend API Designer – Technical Overview

Take a look at this technical overview video of Talend API Designer

Watch Now

Getting Started with APIs

Find out how to get started with APIs

Read