Data not processing

Six Stars

Data not processing

Hi, I am trying to read a tab delimited CSV file and I have set up the input schema as string and length 200 with 0 precision. I am writing it directly to a file using a tmap.

 

While processing the data it is dropping the record and giving me the below message.

 

[statistics] connecting to socket on port 3453
[statistics] connected
For input string: "-37.66"
[ERROR]: talend_default.t_file_0_1.t__FILE - tFileInputDelimited_1 - For input string: "-37.66"

 

In the tFileInputDelimited advanced, I have selected  "Trim All columns". to trim white space.

So does anyone have an idea to resolve the issue?


Accepted Solutions
Moderator

Re: Data not processing

Hello,

What does your tab delimited CSV file look like? Could you please give us some sample content for testing? Are you able to create file delimited metadata via your CSV file to see if it can be previewed successfully with custom encoding UTF-16LE?

Best regards

Sabrina

 

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.

View solution in original post


All Replies
Moderator

Re: Data not processing

Hello,

What does your tab delimited CSV file look like? Could you please give us some sample content for testing? Are you able to create file delimited metadata via your CSV file to see if it can be previewed successfully with custom encoding UTF-16LE?

Best regards

Sabrina

 

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.

View solution in original post

Six Stars

Re: Data not processing

Hi Sabrina,

 

Thanks a lot for your response. The sample data is in below:

NameService ChargeBalanceAmount
Steve43-37.66210
Castro02020

 

The red highlighted record is not processing. Even with the data viewer, I am not able to see the data for STEVE

Right Click on Input Delimited> Data Viewer it's not showing the data.

I have also attached the metadata settings. Please take a look. As per my understanding,

the issue is with the metadata setup. For input, I have set up everything as a string and writing it as a string.

Six Stars

Re: Data not processing

Hi Sabrina, the issue is resolved but I am not sure how.
Highlighted
Moderator

Re: Data not processing

Hello,

Feel free to let us know if this issue repro again from your end.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.

2019 GARNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

Best Practices for Using Context Variables with Talend – Part 1

Learn how to do cool things with Context Variables

Blog

Migrate Data from one Database to another with one Job using the Dynamic Schema

Find out how to migrate from one database to another using the Dynamic schema

Blog

Best Practices for Using Context Variables with Talend – Part 4

Pick up some tips and tricks with Context Variables

Blog