DB Connection can't retrieve schema for AS400 Database in Talend 5.2.1

One Star

DB Connection can't retrieve schema for AS400 Database in Talend 5.2.1

Hello everyone,
I have just installed the new release of Talend, 5.2.1, which looks quite nice from a user interface point of view.
However, the first job I tried to create using my new installation failed to retrieve schemas from my AS400 database.
I checked all my configuration and it was all correct; and when I tried the same configuration on my 5.1.1 instance, it all worked fine.
Has anyone experienced the same? Am I doing anything wrong? Is this a bug in 5.2.1?
I would appreciate any feedback on this.
Many thanks,
Julipool
One Star

Re: DB Connection can't retrieve schema for AS400 Database in Talend 5.2.1

Hello,
change your configuration does not specify the parameter database.
One Star

Re: DB Connection can't retrieve schema for AS400 Database in Talend 5.2.1

Hi Julipool
I have a similar problem to connect AS400 DB on Talend 5.2.0.
When I would like to get a schema from my library I haven't le list of tables of views (see first image).
This behaviour is different between kind of Db (so, on MS SQL I can to display a list of tables and views).
To resolve this I skip to the step, click the refresh button and then I have the drop down list with all tables (see second image).
I seed also that when on configure the connection the check is right also if the name database is wrong; you have to check if this parameter is correct.
Regards
Alessandro
One Star

Re: DB Connection can't retrieve schema for AS400 Database in Talend 5.2.1

Hi Alessandro.Cic,
Many thanks for your response, this is a good work around which also worked for me.
I found another way of getting the AS400 connection to work, and it consists of importing the DB Connection Metadata from a previous version of Talend, and it also works, so you can retrieve data from the AS400.
However, I still think this is a bug in the new Talend release, because it does not allow to retrieve the schemas as you could with previous releases.
Best regards,
Julipool
Employee

Re: DB Connection can't retrieve schema for AS400 Database in Talend 5.2.1

Hi,
here is the link to the issue: https://jira.talendforge.org/browse/TDI-24662
It's fixed in 5.2.2.

Calling Talend Open Studio Users

The first 100 community members completing the Open Studio survey win a $10 gift voucher.

Start the survey

2019 GARNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

Best Practices for Using Context Variables with Talend – Part 4

Pick up some tips and tricks with Context Variables

Blog

How Media Organizations Achieved Success with Data Integration

Learn how media organizations have achieved success with Data Integration

Read

Downloads and Trials

Test drive Talend's enterprise products.

Downloads