Custom Modules in SugarCRM using tSugarCRMInput_1

One Star

Custom Modules in SugarCRM using tSugarCRMInput_1

Hi all,
I have a custom package and module in SugarCRM. The package name is "Training_Package" and the module name is "Training".
When using tSugarCRMInput to get a list of records, the error I get is:
Starting job ListTrainingRecodsInSugar_std at 16:13 14/02/2013.
connecting to socket on port 4070
connected
Error Code:20
Module Does Not Exist
This module is not available on this server
disconnected
Job ListTrainingRecodsInSugar_std ended at 16:13 14/02/2013.
Now the error seems to me very obvious, that I've input the name of the package or module wrongly. But I'd checked and checked and re-checked.
Refer to the attached Screenshots, is there something I've missed?
I can successfully connect to standard SugarCRM modules (i.e. Contacts) for this same site.
SugarCRM Version 6.6.1 (Build 1345), ondemand, and TOS for DI 5.2.1r95165.
One Star

Re: Custom Modules in SugarCRM using tSugarCRMInput_1

Instead of using the format of "<packagename>_<modulename>", it turns out that I needed to use the format of "<packageprefix>_<modulename>". The package prefix is listed as the "Key" on the details page of the package in Admin area of SugarCRM.
This means that what I needed to input for the custom module name was "train_training" instead of "Training_Package_Training". Now that I've done that, I can access the custom SugarCRM Module.
One Star

Re: Custom Modules in SugarCRM using tSugarCRMInput_1

Hi , i'll be very happy if you could help me,
i'm using the package OpenQuotesAndContracts that has the key = "oqc"
i insert "Custom module Package Name" = "oqc_Products" and "Custom Module Name" = "Products"
but all i get in the schema is the defualt module that was before it - Contacts.
also if i add a tmap, i also get the Contacts table in it , not the Products.
i can't get it to work.
can someone help me?
One Star

Re: Custom Modules in SugarCRM using tSugarCRMInput_1

Instead of using the format of "<packagename>_<modulename>", it turns out that I needed to use the format of "<packageprefix>_<modulename>". The package prefix is listed as the "Key" on the details page of the package in Admin area of SugarCRM.
This means that what I needed to input for the custom module name was "train_training" instead of "Training_Package_Training". Now that I've done that, I can access the custom SugarCRM Module.

hi ben,
it seems to me that you not only changed the notation, but also use another sugar component?
I am trying to import data into a sugar custom module as well and just cant get it to work.
As far as I can tell does the TOS Sugar connector concatenate the Sugar module name from the key and the module name and puts an underscore between these two.
So that it has the exact module name that you see in your Sugar URL when browsing the custom module there.
e.g. "buch1_Reservation"
I did enter the data into the 2 fields of the connector, but no sucess, it wont load the scheme.
For any hints... you know.. Smiley Happy