Connection with Microsoft Dynamics CRM

One Star

Connection with Microsoft Dynamics CRM

Hi all,
I can't get the component tMicrosoftCrmInput to work well. Has anyone ever managed to run this component? There are not so much discussions on it on the Internet ...
Thanks,
Thibault
One Star

Re: Connection with Microsoft Dynamics CRM

Hi Thibault
Welcome to Talend Community!
Did you get any error?
Have you read the instructions and scenario about tMicrosoftCRM components with the document ?
Regards,
Pedro
One Star

Re: Connection with Microsoft Dynamics CRM

Hi Pedro,
Thank you !
I get the following error whenever I try to execute my job :

Exception in component tMicrosoftCrmInput_1
org.apache.axis2.AxisFault: Transport error: 401 Error: Unauthorized
at org.apache.axis2.transport.http.HTTPSender.handleResponse(HTTPSender.java:295)
at org.apache.axis2.transport.http.HTTPSender.sendViaPost(HTTPSender.java:190)
at org.apache.axis2.transport.http.HTTPSender.send(HTTPSender.java:75)
at org.apache.axis2.transport.http.CommonsHTTPTransportSender.writeMessageWithCommons(CommonsHTTPTransportSender.java:389)
at org.apache.axis2.transport.http.CommonsHTTPTransportSender.invoke(CommonsHTTPTransportSender.java:222)
at org.apache.axis2.engine.AxisEngine.send(AxisEngine.java:435)
at org.apache.axis2.description.OutInAxisOperationClient.send(OutInAxisOperation.java:402)
at org.apache.axis2.description.OutInAxisOperationClient.executeImpl(OutInAxisOperation.java:229)
at org.apache.axis2.client.OperationClient.execute(OperationClient.java:165)
at com.microsoft.crm4.webserviceTest.CrmServiceStub.execute(CrmServiceStub.java:2268)
at migration_crm.test_0_1.test.tMicrosoftCrmInput_1Process(test.java:2653)
at migration_crm.test_0_1.test.runJobInTOS(test.java:8057)
at migration_crm.test_0_1.test.main(test.java:7925)
The authentication is set as ON_PREMISE, in the component's parameters by the way. And yes, I already read the instructions about the tMicrosoftCrmInput in the documentation.
So, any idea are welcome !
One Star

Re: Connection with Microsoft Dynamics CRM

I get the same issue - tried every service including the /2007 ones and can't get anything to connect for CRM Dynamics 2011.