Connection Issue with SAP Java Connector 2.1.9

One Star

Connection Issue with SAP Java Connector 2.1.9

After installing the new SAP Java Connector I am having the the following problem:
Connection failure. You must change the SAP Settings.
JCO.classInitialize(): Could not load middleware layer 'com.sap.mw.jco.rfc.MiddlewareRFC'
JCO.nativeInit(): Could not initialize dynamic link library sapjcorfc. Found version "2.1.9 (2010-01-28)" but required version "2.1.8 (2006-12-11)".
Please make sure you have installed native libraries for SAP.
What is this related about? I have replaced the sapjco.jar in lib/java and also both dll inside windows/system32
Community Manager

Re: Connection Issue with SAP Java Connector 2.1.9

Hello
As the error message shows, it requires version 2.1.8. See SAP connector installation doc on 4696.
Best regards
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: Connection Issue with SAP Java Connector 2.1.9

shong,
I have tried to look for the 2.1.8 inside SAP Service Marketplace, is just not there anymore.
One Star

Re: Connection Issue with SAP Java Connector 2.1.9

Shong, the SAP JCO version 2.1.8 is no longer supported by SAP and has been removed from the SAP download site.
Supported versions currently are 2.1.9 and 3.0.4.
So, it appears that unless the integrator already have JCO version 2.1.8 installed, the Talend SAP connector no longer functions as described.
One Star

Re: Connection Issue with SAP Java Connector 2.1.9

This problema has only been solved on TIS 3.2.1 using SAP Java Connector 2.1.8
If someone is having the same problem, contact me cause I managed to get the older version that is not available anymore on SSM.
One Star

Re: Connection Issue with SAP Java Connector 2.1.9

As this issue has yet to be resolved I am posting a link to download the 2.1.8 SAP Java Connector
http://rapidshare.com/files/451411966/SAP218Connector.zip
One Star

Re: Connection Issue with SAP Java Connector 2.1.9

As this issue has yet to be resolved I am posting a link to download the 2.1.8 SAP Java Connector
http://rapidshare.com/files/451411966/SAP218Connector.zip

If you cannot download you still can contact me by my e-mail and I will send you
Community Manager

Re: Connection Issue with SAP Java Connector 2.1.9

Hi oozaki
I am glad to see you come back to forum again Smiley Wink and thanks for your sharing.
Best regards
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: Connection Issue with SAP Java Connector 2.1.9

Hello, is Talend planning to support sap jco 2.1.9 or 3.0.4 in the (near) future? As sap jco 2.1.8 is no longer supported from sap, it would be nice to work with a supported version of sap jco.
One Star

Re: Connection Issue with SAP Java Connector 2.1.9

Hi All,
I am also getting the same error. It is showing that you have 2.1.7 but required version 2.1.8. We don't have account in sap market place. Is there any another way to download it?