Connecting to SQLExpress 2012

One Star

Connecting to SQLExpress 2012

I am a newbie just trialing the software to do some data migrations.
I am running on windows 7 with Talend Open Studio 5.3.1
I have tried the latest Java..
I can connect through to Oracle no problem but I have SQLExpress 2012 on my PC and regardless of what I try I can't connect to this instance.
Named pipes and TCP/IP on port 1433 are enabled.
A colleague can connect to my instance of SQLEXpress so the port is open as far as I can see.
I have my IP address, PC Name, localhost and 127... as the server.
I have tried these in the further parameters -- INSTANCE=SQLExpress
Nothing appears to work.
Any ideas would be gratefully accepted.
Regards
MM
One Star

Re: Connecting to SQLExpress 2012

Are you receiving any messages?
What Authentication mode are you using? Try Sql Server authentication if you haven't already.
One Star

Re: Connecting to SQLExpress 2012

Hi Mike
Thanks for the quick response and the suggestion, sorry I didn't respond back quicker
I am spending too much time in meetings!!
I have tried with both Windows and Sql server authentication.
So I'm still no further on.
If you have any other suggestions I will happily take them.
Regards
Mark
One Star

Re: Connecting to SQLExpress 2012

Hi Just confirm I have used ESF Database migration toolkit and connected to SQLExpress using
SQLServer (windows authentication) and quite easily migrate a table through that tool
ESF settings
Server set as "MYPC\SQLEXPRESS", database set as "XXXX_owner" and schema "guest" the user "sa" and port 1433.
The ESF is no good for me as I will need to do data transformations during migration so thats why I wanted to use Talend.
However I have tried every combination I can think of with Talend and I still can't connect..
One Star

Re: Connecting to SQLExpress 2012

I searched the boards and online help for this and this is the closest match that I could find for my issue which is similar.
I am trying to connect to a local installation of SQL Server 2012 on my laptop.
I get this error dialog "Connection Failure: You must change the Database Settings"
I try to use the same settings to connect via the SSMS client and it connects fine.
I'm logging in with "sa" and its password using SQL Server Authentication, but I've also tried to login with Windows Authentication as well and not working (but does work again from SSMS)

Using this JDBC connection string where <server> is filled in my local SQL Server name without the angle brackets. It is just a defaulted instance - thus no specific instance installed. I checked that 1433 is correct and active via the SQL Server Configuration Manager.
jdbc:jtds:sqlserver://<server>:1433/;
Also tried to enter a DB I have on the connection string but didn't do any good.
Am I missing a driver jar for 2012? Kind of figured by now that it would be included as part of the install.

Appreciate any assistance that can be given.