One Star

Connecting to SQL Server Database with SSL Enabled

I'm having trouble connecting to a SQL Server Database (2008) with SSL Enabled.
I have followed the steps in bug TDI-32738
I have setup a Metadata->Db Connections->{MySQLConnection} using the Wizard which won't connect to the database and returns the following error:
Connection failure. You must change the Database Settings.
 java.lang.RuntimeException: java.sql.SQLException: I/O Error: Socket closed

But when I use a tMSSqlConnection component and connect it to the above item via the Repository and add JVM Arguments -Djsse.enableCBCProtection=false  to the Job, it connects to the database, and returns data.    
But How can I get my Connection in the Metadata to connect to the Database?, so I can define the Table schemas??
Community Manager

Re: Connecting to SQL Server Database with SSL Enabled

This is the solution provided in the jira issue TDI-32738
Start studio with vm argument -Djsse.enableCBCProtection=false
and in the db wizard add additional param encrypt=true;trustServerCertificate=true;ssl=require .
It can make the db wizard work without problem .
When run a job with MSSQL component , need to add vm argument -Djsse.enableCBCProtection=false
in Run view > advanced settings > Use specific JVM arguments.

You need to add the VM argument to the studio configuration file such as TOS_DI-win-x86_64.ini which is located in <studio install dir> directory before starting Talend Studio.
Best regards
Talend | Data Agility for Modern Business
One Star

Re: Connecting to SQL Server Database with SSL Enabled

Thanks that worked.
It wasn't clear in bug TDI-32738  where the VM argument was meant to go for the Open Studio settings.
Is there any plans to fit this in future releases? Won't this make the Connection vulnerable to the SSL BEAST attacks?