Compatibility between TOS DI and postgreSQL v10

Six Stars

Compatibility between TOS DI and postgreSQL v10

Hello,

I did not find any information about this in user documents or on Google so I ask the question here: can we attack a database postgreSQL V10 with TOS DI, and if so from what version?

In 6.4.1 I have problems ...

Thanks in advance.

Cédric.


Accepted Solutions
Six Stars

Re: Compatibility between TOS DI and postgreSQL v10

I confirm TOS DI (since v6.2 ?) is compatible with postgreSQL v10 !

Problem solve

Thx


All Replies
Sixteen Stars

Re: Compatibility between TOS DI and postgreSQL v10

I've just checked on v6.5 and it seems to suggest that only 9 and below are supported. However, that doesn't mean that you won't be able to connect. What is your issue?

Six Stars

Re: Compatibility between TOS DI and postgreSQL v10

Hi

 

Thx for your answer

 

I can't create connection :

 

Sans titre.jpg

 

String connection is ok...

 

Thx for your help

Six Stars

Re: Compatibility between TOS DI and postgreSQL v10

Nobody has the answer ? 

Highlighted
Sixteen Stars

Re: Compatibility between TOS DI and postgreSQL v10

I don't really ever use PostgreSQL but thought I would give this a try. So I installed it (version 10.2) on my MacBook Pro and thought it would just take tweaking the Jar supplied to Talend. But it just worked. Here is a screenshot of my connection....

Screen Shot 2018-02-27 at 22.36.33.png

I am running Talend 6.5 on my Mac, a fresh install, with no modifications. 

 

I then looked at your error message and it appears to say (I do not speak much French) that the database does not exist. I then pointed my connection to a DB that does not exist and got what I believe is the same error message in English. This can be seen below....

Screen Shot 2018-02-27 at 22.33.41.png

 

So unless this is caused by an OS difference (a possibility), I would say there is maybe something wrong with your database. As I said, I do not know PostgreSQL very well, but this shows that version 10 does work....even though it is not supported.

Six Stars

Re: Compatibility between TOS DI and postgreSQL v10

Thank you for this feedback and your efforts!
I will continue my research ...

Regards

Six Stars

Re: Compatibility between TOS DI and postgreSQL v10

I confirm TOS DI (since v6.2 ?) is compatible with postgreSQL v10 !

Problem solve

Thx

Seventeen Stars

Re: Compatibility between TOS DI and postgreSQL v10

Nevertheless Talend could update the driver!