One Star

Cant set a default for date context variable

hi,
i am not able to set a default value for a date context value.
I am able to define the variable. If i set the default value it is shown in the default field.
But if i close the windows by hiting "finish" and open the window again the default is empty again.
If i try to use the variable it is acting like it is empty.
Is this a bug or am i doing somtething wrong?
I am using talend 5.6.1 on windows 7 64 bit.
4 REPLIES
Moderator

Re: Cant set a default for date context variable

Hi,
We made a testing on 5.6 and everything is OK. Could you please show us your Context setting screenshots and more information how to repro it?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Cant set a default for date context variable

I am working with a local repo.
1) i open my context in my case meta--> click next

2) click default and set a date via the pop up. The value is displayed and i hit finish

3) open the context again and the default value is empty. If i reed the value via tcontextdump i see its emtpy, too.
Moderator

Re: Cant set a default for date context variable

Hi,
Please try to move your mouse away from "Value" column and don't focus your mouse on current value(you can click last one to avoid that) then clicking Next or Finish button.
It seems this issue just repro on"Date" data type.

Best regards
Sabrina


--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Cant set a default for date context variable

That works. Thanks a lot for your help.
Should i create a report on the bugtracker or have you already done that?