Four Stars

Cannot update Salesforce API version 38

 

I successfully created a metadata and connection to a production Salesforce instance using the API version 37 as described in the Talend Open Studio 6.3.1 documentation. I use a Basic connection type. 

 

I need to use the Salesforce API version 38 to update a geolocalisation field (see Salesforce doc), so I updated the Salesforce URL to "https://www.salesforce.com/services/Soap/u/38.0".

 

When testing the connection, I have the following error message:

Screenshot from 2017-05-04 10-15-45.png

 

If I update the  Salesforce URL in the tSalesforceInput component I have the following trace:

 

 

Exception in component tSalesforceInput_1
java.lang.RuntimeException: com.sforce.ws.ConnectionException: unable to find end tag at:  START_TAG seen ...</orgDefaultCurrencyIsoCode><orgDefaultCurrencyLocale>... @1:901
	at custforthnew.import_account_0_1.Import_Account.tSalesforceInput_1Process(Import_Account.java:4964)
	at custforthnew.import_account_0_1.Import_Account.runJobInTOS(Import_Account.java:7598)
	at custforthnew.import_account_0_1.Import_Account.main(Import_Account.java:7455)

 

What I am missing? 

Tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Moderator

Re: Cannot update Salesforce API version 38

Hello,

Please take a look at online document about:Supported+systems+databases+and+business+applications+by+Talend+components for 6.3

Salesforce-->V37 and earlier

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
3 REPLIES
Moderator

Re: Cannot update Salesforce API version 38

Hello,

Please take a look at online document about:Supported+systems+databases+and+business+applications+by+Talend+components for 6.3

Salesforce-->V37 and earlier

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Four Stars

Re: Cannot update Salesforce API version 38

Any update on this if Talend now supports Salesforce v38.0? 

 

The URL in the post is not working and it shows page not found message.

Moderator

Re: Cannot update Salesforce API version 38

Hi,

Please take a look at this latest document about:TalendHelpCenter: Supported systems, databases and business applications by Talend components for 6.4

Salesforce-->V39 and earlier

Best regards

Sabrina

 

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.