Cannot run TOS for ESB -

One Star

Cannot run TOS for ESB -

I have a 64 bit machine. When I run TOS_ESB-win-x86_64 I immediately get "Failed to load the .INI shared library "C:\Program Files (x86)\Java\jre7\bin\client\jvm.dll"." This file exists in that location. 
When I run TOS_ESB-win32-x86 I briefly get the splash screen followed by "An error has occurred. See log file null." The log file (which I found in the "configuration" folder) contains the below.
Background is that I have been running TOS for DI and DQ quite happily for a few weeks with no complaint. They still work fine.

Any ideas?
Charlie

!SESSION 2016-06-22 14:37:14.020 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.7.0_79
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_GB
!ENTRY org.eclipse.osgi 4 0 2016-06-22 14:37:14.223
!MESSAGE error loading hook: org.talend.osgi.configurator.JarLoaderConfigurator
!STACK 0
java.lang.UnsupportedClassVersionError: org/talend/osgi/configurator/JarLoaderConfigurator : Unsupported major.minor version 52.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(Unknown Source)
at java.security.SecureClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.access$100(Unknown Source)
at java.net.URLClassLoader$1.run(Unknown Source)
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Unknown Source)
at org.eclipse.osgi.internal.hookregistry.HookRegistry.loadConfigurators(HookRegistry.java:185)
at org.eclipse.osgi.internal.hookregistry.HookRegistry.initialize(HookRegistry.java:106)
at org.eclipse.osgi.internal.framework.EquinoxContainer.<init>(EquinoxContainer.java:73)
at org.eclipse.osgi.launch.Equinox.<init>(Equinox.java:31)
at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:295)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:231)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:648)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:603)
at org.eclipse.equinox.launcher.Main.run(Main.java:1465)
One Star

Re: Cannot run TOS for ESB -

PS I get the same errors when I try to run TOS for Big Data, which I just downloaded. Meanwhile TOS for DI continues working fine...
One Star

Re: Cannot run TOS for ESB -

OK, I got it to work by upgrading to JRE1.8, even though the guidelines say 1.7 and I had 1.7.