Can Talend DI v6.1.1 supports Java version 5, 6 or 7

One Star

Can Talend DI v6.1.1 supports Java version 5, 6 or 7

Hi,
On below guide link they've mentioned that for Talend DI version 6.1 the recommended version of Java is 8. But whether it supports the lower versions of Java. Like JDK 5, 6 or 7.. ?
Community Manager

Re: Can Talend DI v6.1.1 supports Java version 5, 6 or 7

As JDK 5, 6 and 7 are out of support with Oracle, we cannot provide support on those and we do not QA those.
However we know from some of our users that 7 should be ok and 6 could be ok for most of the simple parts but may be blocking on some use cases.
HTH
One Star dbh
One Star

Re: Can Talend DI v6.1.1 supports Java version 5, 6 or 7

I have tried TOS 6.1.1 with Java 8 as well as 7. It seems to work fine in both. I have not tried it with an earlier JDK. 
Seriously though Java 1.8 has been out for over a year and 7 is now no longer supported unless you pas for updates from Sun/Oracle
Try out Java 8! Smiley Happy
One Star

Re: Can Talend DI v6.1.1 supports Java version 5, 6 or 7

Hi Team,
I am facing a the below error while trying to establish a HDFS connection in Talend BigData 6.2.1
"Error Line: 317
Detail Message: nn cannot be resolved to a variable
There may be some other errors caused by JVM compatibility. Make sure your JVM setup is similar to the studio."
I have rechecked the java jre version in talend and is mapped to the jre8 version .
please help me with a resolution.
Ten Stars

Re: Can Talend DI v6.1.1 supports Java version 5, 6 or 7

Talend requires the Java JDK rather than just the JRE.  Try installing and mapping the Java 8 JDK and see if that fixes your problem.