Built Neo4j Job and Null Pointer Exception on tNeo4jOutput_2

One Star

Built Neo4j Job and Null Pointer Exception on tNeo4jOutput_2

I am currently transferring all my data from a RDBMS (Postgres) to Neo4j 1.9.6. I have built a Job that runs perfectly within the Talend interface. But then when I build and export the job script (jar with the executable bash script), the software fails to run. It gives me the following error:
Exception in component tNeo4jOutput_2
java.lang.NullPointerException
at postgres.tPostgresqlInput_1Process(postgres.java:2049)
at postgres.tPostgresqlConnection_1Process(postgres.java:619)
at postgres.runJobInTOS(postgres.java:5871)
at postgres.main(postgres.java:5760)
I tried to debug the generated script and imported it along with the libraries to Netbeans 8.0. Here are the culprit lines of code:
indexNodeMap_tNeo4jOutput_2.put(
"label_idx",
databaseService_tNeo4jOutput_2.index().forNodes(
"label_idx"));
It does not matter if I comment out this piece of code, because then the program crashes on the next reference to tNeo4jOutput2.
Any idea what is going wrong? And why does it work perfectly from within Talend Open Studio?
Moderator

Re: Built Neo4j Job and Null Pointer Exception on tNeo4jOutput_2

Hi,
Is it working well for you when using TalendHelpCenter:tLogrow instead of tNeo4jOutput?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Built Neo4j Job and Null Pointer Exception on tNeo4jOutput_2

It does!
Moderator

Re: Built Neo4j Job and Null Pointer Exception on tNeo4jOutput_2

Hi,
How did you set your TalendHelpCenter:tNeo4jOutput? Would you mind posting component setting screenshots into forum?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Built Neo4j Job and Null Pointer Exception on tNeo4jOutput_2

Like this...
Moderator

Re: Built Neo4j Job and Null Pointer Exception on tNeo4jOutput_2

Hi,
Did you create some custom routine in your job? If so, have you already checked "job dependencies" when export job?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Built Neo4j Job and Null Pointer Exception on tNeo4jOutput_2

Yes, and I have made sure that talend is sending all the "tar" files with the script, and that it puts the right classpath for the jars in the executable bash file.