Building Job: Structures not being exported when running from command line

Five Stars

Building Job: Structures not being exported when running from command line

I have a job which uses datamapper. When I am exporting the job from command line below is the command I am using but the Structures are not exporting into the zip file created. I have attached the screen shot of the zip file. I could see Structures in BitBucket for the tag I am building the job, but it's not just exporting when using the below command.

 

 

buildJob <JOB_NAME> -dd <destination_dir> -il –maven

 

 

Moderator

Re: Building Job: Structures not being exported when running from command line

Hello,

Are you able to run your job successfully in studio?

Job generation from TAC uses the CommandLine started in server mode, which has deprecated since Talend version 7.01.

Talend recommends using one of the three options below to build/publish Jobs, then create the tasks in TAC using the .zip file generated from the build/publish process:

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.

2019 GARTNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

Best Practices for Using Context Variables with Talend – Part 1

Learn how to do cool things with Context Variables

Blog

Migrate Data from one Database to another with one Job using the Dynamic Schema

Find out how to migrate from one database to another using the Dynamic schema

Blog

Best Practices for Using Context Variables with Talend – Part 4

Pick up some tips and tricks with Context Variables

Blog