Five Stars

Bug in Talend Data mapper 6.0.1

Hi

 

I'm using Talend data mapper for converting EDI to Flat file.

In my input edi File...And word is coming like this "JA??PAN"

And I've already set ? as a release character in Input EDI structure's representation properties.

 

So when I get a output..it comes like this...."JAPAN". Its should be only one release character but it removing the second one as well.

 

Actual Output should be like this "JA?PAN"

Input file format UTF-8 and output as well.

 

Please suggest...!

  • Data Integration
Tags (1)
8 REPLIES
Moderator

Re: Bug in Talend Data mapper 6.0.1

Hi,

Thanks for posting your issue here. Does this issue repro when use another EDI File? Could you please give us more information about your data mapper setting so that we can make a testing to see if it is a bug on V 6.0.1

Best regards

Sabrina

Five Stars

Re: Bug in Talend Data mapper 6.0.1

Yes..Its happening with mine other two EDI files as well.

 

In input EDI structure...Under representation of EDI Input structure, In EDI setting I've set up a "?" as release character. But its not working as expected. And in output its not showing result as expected mentioned in my question - First comment.

 

Please update me on this ASAP.

 

Five Stars

Re: Bug in Talend Data mapper 6.0.1

And my output is Flat structure.  Creating my output is using tfileoutputraw under encoding type utf-8.

 And both structures encoding type is set at default platform option.

 

 

Five Stars

Re: Bug in Talend Data mapper 6.0.1

Any update Sabrina...?

 

Thanks

Tags (1)
Moderator

Re: Bug in Talend Data mapper 6.0.1

Hi,

Could you please send your EDI file to us for a testing? The setting screenshot of data mapper will be preferred.  With your subscription solution, have you already created a case on talend support portal so that we can give you a remote assistance through support cycle with priority?

Best regards

Sabrina

 

Five Stars

Re: Bug in Talend Data mapper 6.0.1

Hi Sabrina..!!

 

Data I cant share with you...!! Secondly, I've set up a correct settings in Input EDI structure in Talend Data mapper.

 

Here are the Configuration List:

EDItype: EDIFACT
EDI Element name convention: Element is Segment/Sequence(SEGss)
Import into directory:
Import codes?: tick
Import codes into directory?:tick
Ignore objects marked "Excluded"?tick
Segment delimiter: '
Element delimiter: +
Composite sub-element delimiter: :
Sub component delimiter(HL7 only):
Repetition delimiter: ^
Decimal character: .
Release character: ?
Character Encoding: Platform Default

Trim whitespace on input? tick
Pad to minimum length on output? tick

 

I can tell you about file type ...!! Encoding type is UTF-8 and am sure you must be having any edi having and you can set up a situation where a word is holding double question mark in it eg JA??PAN

 

After having these setting am getting output like this JAPAN instead of JA?PAN

 

I hope this matter is sufficient to test your product. Because in same file am having other special characters, they are working fine.

 

Please update me ASAP on this, Its a process breaking situation.

 

Thanks

 

Moderator

Re: Bug in Talend Data mapper 6.0.1

Hello,

It's a little hard for us to repro your issue without input data.

Could you please create a case on talend support portal so that we can give you a remote assistance(webex) through support cycle with priority to see if it is a bug in Talend Data mapper V 6.0.1?

Best regards

Sabrina

Six Stars

Re: Bug in Talend Data mapper 6.0.1

Hi,

 

What is your input file ? What is your output file ?

 

NB: Now you should be able to upload your test data.

 

Eric