One Star

Adjust the MaxIdleTimeout of the jetty server which was created by CXF

Dear all,
I'am using TalendESB 5.11 Standard Edition (has camel 9.2.4 in it).
The camel routes are implemented with eclipse in java dsl. I have several web service interface based on CXF.
On web service does much work so the client's request may hung a while before my web service can generate the response an finished.
Often after aprox. 200 secondes a server side timeout closes the socket so what the client gets an exception. The reason for that is the default value of the Jetty Connector MaxIdleTime is set to 200 seconds. (see screenshot).
My question is: How can I change the value of the MaxIdleTime?
My web service is implemented like this:
1) Spring based configuration of the camel-cxf endpoint:
 <cxf:cxfEndpoint id="hazmatLookup"
  address=""
  serviceClass="aero.ltls.salt.esb.route.ltl_slt_lst_hazmat_01.ws.hazmatlookup.HazmatLookup">
  <cxf:inInterceptors>
         <ref bean="authentificationInterceptorBean"/>
        </cxf:inInterceptors>        
 </cxf:cxfEndpoint>
2) Java dsl of my route:
 from(cxf:bean:hazmatLookup?loggingFeatureEnabled=true&loggingSizeLimit=10485760).routeId("ROUTE_NAME_IN_HAZMAT_LOOKUP")
  .autoStartup(autostartupLgwLst) 
  ...
 
 
Thanks and Regards´
Michael Kreher
1 REPLY
Employee

Re: Adjust the MaxIdleTimeout of the jetty server which was created by CXF

Hi,
as much as I know you can't directly set the Jetty MaxIdleTimeout in this context / within your spring route. But did you tried if these two connection parameter would solve your problem, using a http-conduit confirguation within your Spring Route?
http://stackoverflow.com/questions/20473477/camel-how-to-set-cxf-client-timeout
Do you mean Talend ESB 5.1.1. and Camel 2.4.9 - quite old, but guess you know this.
Thanks,
Dietmar