One Star

Accent problem with TeradataInput and tFileOutputDelimited

Hello,
Excuse me for my poor English.
I try to export data from teradata database to multiple CSV files.
I need to keep accents on my csv files, but i cant do it.
I use : 
TeradataConnection > TeradataInput > tMap > FileOutputDelimited (x3)
When I use ISO encodage I got "?" in the place of accents.
When I use UTF8 encodage I got "�"
I try to change the Encodage in : 
- The FileOuput composant.
- The Connection composant with : characterEncoding.
- The Workspace preference.
6 REPLIES
One Star

Re: Accent problem with TeradataInput and tFileOutputDelimited

Can you post here component's properties screen shot here ?
One Star

Re: Accent problem with TeradataInput and tFileOutputDelimited

Connection properties :

FileOutPut properties:
Moderator

Re: Accent problem with TeradataInput and tFileOutputDelimited

Hi CharlyFR,
Have you tried to add the parameter "Dfile.encoding=utf-8" to the JVM parameters to see if it  works?
Best regards
Sabrina
 
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Accent problem with TeradataInput and tFileOutputDelimited

Hi xdshi and thanks for your help,
I try to add "Dfile.encoding=utf-8" to the JVM parameters, But i got the same result : "�" in place of accents.
Charly.
Moderator

Re: Accent problem with TeradataInput and tFileOutputDelimited

Hi,
Have you already also added the parameter in "Additional JDBC parameters" of tTeradataInput component? What does your expected accents look like?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Accent problem with TeradataInput and tFileOutputDelimited

Hi,
I try to add characterEncoding in JDBC parameters of tTerdataInput but always got "�" in place of accents, my accent look like "é"
I try to run tTeradataInput solo with result in console (tlogrow) and in console i got this caracter "�" in place of accent too : 
Charly