AS400 - Talend cannot find table

Four Stars

AS400 - Talend cannot find table

Hello to all!

 

I need to make an insert into an AS400 table, the same operation I've already done in a different job, but these time Talend cannot find the specified table in the database to retrieve it's schema.

 

The funny thing is that I'm able to select it from the Talend SQL Builder and from DBeaver.

 

Things I've already tried, that I found on the Talend Community:

- When retrieving the schema in the metadata, check connection buttom doesn't help.

When retrieving the schema in the metadata, select all that appear and then next. The table doesn't appear in the next screen.

 

The database name is 'LHDADDBPD' and the table is 'EIPDPCV'.

 

I'm using Talend DI Open Studio v7.0.1. 

 

Attached are some prints, showing that the table does not appear in the metadata retrieve schema but I can load it in the SQL Builder and, when I search by name, Talend doesn't find it.

  

Thanks so much for the help!

Thirteen Stars

Re: AS400 - Talend cannot find table

we have same issue - jdbc driver included with Talend not show all tables

solution - use jdbc connection and jdbc driver ver 9.5

 

http://jt400.sourceforge.net

-----------
Eleven Stars

Re: AS400 - Talend cannot find table

some years ago we solve this problem using a jdbc driver.
DB2 and DB2 400 are not using the same system tables.

Francois Denis

Tag as "solved" for others! Kudos to thanks!

Thirteen Stars

Re: AS400 - Talend cannot find table

yes, it may depend from AS400/DB2 version (or settings)

 

on other site - all perfect work with Talend AS400 components

-----------

Tutorial

Introduction to Talend Open Studio for Data Integration.

Definitive Guide to Data Integration

Practical steps to developing your data integration strategy.

Definitive Guide to Data Quality

Create systems and workflow to manage clean data ingestion and data transformation.