Six Stars

tHiveConnection java.lang.NoClassDefFoundError: org/apache/commons/logging/LogFactory

tHiveConnection component.

Any idea on how to solve this issue?


Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/commons/logging/LogFactory
at org.apache.hadoop.security.UserGroupInformation.<clinit>(UserGroupInformation.java:84)
at part_kpi.hive_test_0_1.Hive_Test.tHiveConnection_1Process(Hive_Test.java:370)
at part_kpi.hive_test_0_1.Hive_Test.runJobInTOS(Hive_Test.java:763)
at part_kpi.hive_test_0_1.Hive_Test.main(Hive_Test.java:600)
Caused by: java.lang.ClassNotFoundException: org.apache.commons.logging.LogFactory
at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)

 

I have already downloaded the common-logging library from the Apache website:

http://commons.apache.org/proper/commons-logging/download_logging.cgi

and copied the jar (commons-logging-1.2.jar) here:

<installation-path>/cmdline/studio/plugins

and restart the Job Server... but I was not successful.

 

Regards,

Lorenzo

1 REPLY
Moderator

Re: tHiveConnection java.lang.NoClassDefFoundError: org/apache/commons/logging/LogFactory

Hello,

All jar relative to your component are installed? Did you get this issue when deploy your job on TAC?]

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.