[resolved] java.lang.ClassNotFoundException: oracle.jdbc.driver.OracleDriver

Highlighted
One Star

[resolved] java.lang.ClassNotFoundException: oracle.jdbc.driver.OracleDriver

Hi all,
I have a strange problem.
I have a basic flow which is working well in Talend Studio; However, when I deploy it in my Talend TOS runtime, I get this error :

karaf@trun> Exception in component tOracleConnection_1
java.lang.ClassNotFoundException: oracle.jdbc.driver.OracleDriver
        at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:501)
        at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:421)
        at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:412)
        at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Class.java:191)
        at apprentissage_old.oracletestporttype_oracletestoperation_0_1.OracleTestPortType_OracleTestOperation.tOracleConnection_1Process(OracleTestPortType_OracleTestOperation.java:1508)
        at apprentissage_old.oracletestporttype_oracletestoperation_0_1.OracleTestPortType_OracleTestOperation.tESBProviderRequest_1_LoopProcess(OracleTestPortType_OracleTestOperation.java:1994)
        at apprentissage_old.oracletestporttype_oracletestoperation_0_1.OracleTestPortType_OracleTestOperation.runJobInTOS(OracleTestPortType_OracleTestOperation.java:3170)
        at org.talend.esb.job.controller.internal.RuntimeESBProviderCallback.run(RuntimeESBProviderCallback.java:120)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
        at java.lang.Thread.run(Thread.java:745)


I have tried these changes without sucess :

Change Oracle database parameter version in tOracleInput from 11.6 to 11 and 10 (as sugest here : https://jira.talendforge.org/browse/TDI-18045)
Add a component tOracleConnection before tOracleInput
Check my Eclipse parameters : 
    JRE installed : JRE7 added
    JRE compliance to 1.6 (can not use 1.7)

Thank you for your help !
Regards,
Rahim

One Star

Re: [resolved] java.lang.ClassNotFoundException: oracle.jdbc.driver.OracleDriver

Solution :

add the ojdbc6.jar in the folder jre/lib/ext
set CLASSPATH variable for this above folder

Rahim
One Star

Re: [resolved] java.lang.ClassNotFoundException: oracle.jdbc.driver.OracleDriver

Rahim,
By adding jar in jre/lib/ext didn't work.
But adding jar in >> ..\Runtime_ESBSE\container\lib\ext worked fine and solved the problem.
( As
 )
Six Stars

Re: [resolved] java.lang.ClassNotFoundException: oracle.jdbc.driver.OracleDriver

Hi,

 

I am facing similar issue..

 

Are those folders under talend setup or java .jar files? Not able to find those folders..

 

Thanks,

 

Moderator

Re: [resolved] java.lang.ClassNotFoundException: oracle.jdbc.driver.OracleDriver

Hello,

Please refer to this online document:TalendHelpCenter:Installing external modules and let us know if it is what you are looking for.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

An API-First Approach to Modernizing Applications

Learn how to use an API-First Approach to Modernize your Applications

Watch Now

Talend API Designer – Technical Overview

Take a look at this technical overview video of Talend API Designer

Watch Now

Getting Started with APIs

Find out how to get started with APIs

Read

Definitive Guide to Data Quality

Create systems and workflow to manage clean data ingestion and data transformation.

Download