Two Stars

[resolved] Run job in TAC

Hi All,
i want to run a job from TAC.
I am using job conductor for this operation.
When i try to run the job am getting the fallowing error: Connection to Generator failed (CommandLine)
Do we have to install commandLine which comes with talend ESB or just the job server is enough to run the job server.
Please help me on this.
Thanks,
Bhanu
9 REPLIES
Moderator

Re: [resolved] Run job in TAC

Hi,
When you are using TAC->Job Conductor to deploy jobs on JobServer, the commandline needs to be started up(%TIS%\Commandline.bat or %TIS%\commandline-linux.sh).
Please take a look at document:https://help.talend.com/search/all?query=CommandLine+overview&content-lang=en
Commandline is used to generate and export the Jobs developed with Talend Studio onto the Job servers(Talend Data Integeration), or export Services, Routes and data service Jobs onto Runtime servers(Talend ESB).
Besides, you'd better check the parameters about commandline in TAC->Configuration.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Two Stars

Re: [resolved] Run job in TAC

Hi Sabrina,
I have fallowed the same procedure you mentioned in your reply.
But again facing the same problem while running the job from TAC.
Please help me out that where am i doing wrong.
Bhanu
Moderator

Re: [resolved] Run job in TAC

Hi,
How did you set your commandline in TAC? What's the  status of CommandLine in your Tac console?

Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Two Stars

Re: [resolved] Run job in TAC

Hi,
In TAC the error is showing that both commandlines are down.
I have added two servers in TAC both are up and running.
But the commandline still down. I have turned on the commandline serverices through .bat file.
Still the same error shows in TAC.
-Bhanu
Moderator

Re: [resolved] Run job in TAC

Hi,
Is your job server installed on the same machine as TAC? Have you launched the job server successfully and make sure the job serve is running now?


Best regards
Sabrina 
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Two Stars

Re: [resolved] Run job in TAC

Hi Sabrina,
No my job server and TAC are installed on different machines.
I am accessing the TAC from the machine where the job server is installed. Job conductor also installed on the same machine as job server.
In TAC the job server is up and running.
CommandLine is also running fine but on  TAC i am getting on error that both the commandlines are down.
Thanks,
Bhanu
Moderator

Re: [resolved] Run job in TAC

Hi Bhanu,
Could you please show us your commandline configration screenshot in TAC?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Two Stars

Re: [resolved] Run job in TAC

Hi Sabrina,
Thanks for your response and support in finding the issue.
I have resolved the problem of running the job from TAC.
The problem is with the commandline configuration.
Thanks,
Bhanu
Moderator

Re: [resolved] Run job in TAC

Hi Bhanu,
Thanks for your feedback. Feel free to let us know if there is any further help we can give.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.