One Star

[resolved] New TAC execution server with status down ...

Hi all,
I've created a new job server in the TAC with Talend Runtime flag set to true and default values in all places. Unfortunately the server doesn't come up even so I can see the runtime (karaf) over the port of the admin console. So the runtime is running for me.
In /opt/Talend-5.2.2/tac/archive/logs/administrator.log there are a lot of entries like
2013-05-16 17:03:35 ERROR TalendRuntimeServerStateChecker - init talendRuntime Error!Bad URL path: :44443/jndi/rmi://<hostname> :1098/karaf-trun
that seem to indicate the problem, but they don't help me ...
what do I have to do to correct this failure?
how can I check that the right runtime is up?
what might be the probelm?
Many thanks
Rabe
1 ACCEPTED SOLUTION

Accepted Solutions
One Star

Re: [resolved] New TAC execution server with status down ...

The problem is solved, it was a simple name resolution problem.
The RMI port is a port on the Jobserver hence and the test for availability with the admin console is meaningful!
Bye, Rabe
3 REPLIES
Moderator

Re: [resolved] New TAC execution server with status down ...

Hi,
I've created a new job server in the TAC with Talend Runtime flag set to true and default values in all places. Unfortunately the server doesn't come up even so I can see the runtime (karaf) over the port of the admin console. So the runtime is running for me.
In /opt/Talend-5.2.2/tac/archive/logs/administrator.log there are a lot of entries like
2013-05-16 17:03:35 ERROR TalendRuntimeServerStateChecker - init talendRuntime Error!Bad URL path: :44443/jndi/rmi://<hostname> :1098/karaf-trun
that seem to indicate the problem, but they don't help me ...

I suspect this is a inconsistent issue. From your description, you use default values(it is 44444/1099) but your URL is :44443/jndi/rmi://<hostname> :1098/karaf-trun.
As a work around, check your config file /etc/org.apache.karaf.management.cfg and the
Port Number: "rmiRegistryPort = 1099, rmiServerPort = 44444. " to keep them consistent with your TAC Talend Runtime
If not, check your port number to make sure there is no port conflict.
See my screenshot
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: [resolved] New TAC execution server with status down ...

Hi Sabrina,
thanks for your response and sorry my fault! the rmi port of 44443 results from experimenting with the port number. But the problem is the same with 44444. So my posting was not really clear.
So once again the questions
(1) what might be wrong with the RMI port? Or in other words: who is the server for this port the TAC or the execution server? I.e. can there be more then one execution server entries in the TAC with the same RMI port or must they be different?
(2) how should I check the connection to the runtime / whats the link between TAC and runtime / execution server? Is my check with the port of the admin console meaningful?
(3) okay, probabely the port problem is the reason for the status DOWN in TAC so this question is redundant ...
And please could you say some words to my other posting http://www.talendforge.org/forum/viewtopic.php?id=29623 It's directly related ...
Thank you best regards
Rabe
One Star

Re: [resolved] New TAC execution server with status down ...

The problem is solved, it was a simple name resolution problem.
The RMI port is a port on the Jobserver hence and the test for availability with the admin console is meaningful!
Bye, Rabe